Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I wanted to watch the Olympics, so I installed Miro 5.0.2 (49960df1) on Ubuntu 12.04 32-bit. After downloading the Olympics podcasts, I tried to watch the live streams but I was greeted with these messages despite the fact that I already had Adobe Flash 11.2 installed on my system:

enter image description here

enter image description here

So I tried installing the one from Adobe's website, too. The same video runs without any problem in the browser, but not in Miro. I get the same message every time.

I'd really appreciate any help in solving this problem so that I could watch the live streams on Miro itself.

share|improve this question
Does it play other youtube videos? – John S Gruber Jul 31 '12 at 4:04
Yes. It plays youtube videos without any problem. – Pawan Jul 31 '12 at 14:53
Cf. How do I fix Flash issues... – imz -- Ivan Zakharyaschev Dec 23 '12 at 23:07

I'd suggest you try this from user79939 at How can I watch the NBC Olympics 2012 (USA)?. If it works the basic problem is that the streams are protected content.

As per this post on the Adobe website:

Step One: Install HAL

sudo apt-get install hal

Step Two: Quit your web browser

Step Three: Clean out the Adobe Flash folder:

cd ~/.adobe/Flash_Player rm -rf NativeCache AssetCache APSPrivateData2

This process worked for me. In my case, I'd been able to go to and click the log to begin the verification process, but never given the chance to enter my Comcast credentials. Doing the steps above fixed everything.

share|improve this answer
Apparently, that didn't solve the problem. Hal was already installed and I cleaned the Adobe Flash folder too. I'm using Chromium as the default browser. I tried using Firefox as the default browser, but that too didn't help. – Pawan Aug 1 '12 at 17:18

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.