Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So I've installed want to use the latest NVIDIA driver (302.17) from the x-swats PPA repository which was easy enough

It gives me:

  • Better performance
  • Ability to rotate my secondary display,
  • Managing the gfx natively from the displays applet.

But, after installing it, i there are no resolution options available other than my native resolution so I cannot change the resolution in the display app or nvidia-settings.

Which is annoying when wanting to play games etc in other resolutions.

xrandr -q ,reports no other resolutions than the native one. The driver also seems to have scaling disabled, so games for example, running at a lower resolution aren't scaled up Meaning I get a small centered window on my screen.

According to the documentation resolutions can be added in Xorg.conf, but I cant find any specifics on how to.

share|improve this question
    
There's a reason it's the latest, unofficial, bleeding-edge, beta driver ;) –  izx Jul 30 '12 at 20:52
    
Well the current nvidia drivers are far form bleeding edge. And I cant claim that makes them work well :) Im fairly sure some xorg metamode master knows what needs to be done in xorg –  tomodachi Jul 30 '12 at 21:01

2 Answers 2

up vote 0 down vote accepted

I figured it out myself reading the xorg man pages for nvidia driver and the release notes for the new driver

Apparently it lacks support to detect what resolutions your card / monitor is capbable of because the support is being rewritten.

Adding the resolutions to your xorg.conf file manually allows games etc to swtich to the resolution they require.

to the screen section ( Section "Screen") add the following line:

Option "metamodes" "DFP-0: nvidia-auto-select, DFP-1: nvidia-auto-select; nvidia-auto-select {ViewPortIn=1440x900}; nvidia-auto-select {ViewPortIn=1280x1024}; nvidia-auto-select {ViewPortIn=1280x960}; nvidia-auto-select {ViewPortIn=1280x800}"

If you don't have a xorg.conf file, you can use nvidia-settings to create one for you then append the line stated above to it. to get support for the specified resolutions.

In my case DFP-0 is my primary display output. You can verify the name of your display output with the command:

xrandr -q

from the terminal

share|improve this answer

I managed to solve the same issue by manually installing the Nvidia version 319.49 drivers downloaded from http://www.nvidia.com/Download/index.aspx?lang=en-us

following the procedure described in "Method 4: Manual install from the official site" Note that I have enabled the DKMS option during install, and answered yes to the question on whether to overwrite existing xorg.conf files.

After installing, I rebooted the laptop and in nvidia-settings all resolutions were visible again.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.