Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So I understand that my laptop does not support Nvidia Optimus out of the box (http://askubuntu.com/questions/36930/how-well-do-laptops-with-nvidia-optimus-work), therefore I decided to install Bumblebee, but it doesn't change anything, I get

joe@ubuntu:~$ optirun glxspheres
[ 4447.830749] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver

[ 4447.830844] [ERROR]Aborting because fallback start is disabled.

So, I've tried the Bumblebee "hack" listed on https://github.com/Bumblebee-Project/bbswitch/tree/hack-lenovo. I copied every line below into the terminal, is that what I was supposed to do? I'm a Linux noob.

git clone http://github.com/Bumblebee-Project/bbswitch.git -b hack-lenovo
cd bbswitch
mkdir /usr/src/acpi-handle-hack-0.0.1
cp Makefile acpi-handle-hack.c /usr/src/acpi-handle-hack-0.0.1
cp dkms/acpi-handle-hack.conf /usr/src/acpi-handle-hack-0.0.1/dkms.conf
dkms add acpi-handle-hack/0.0.1
dkms build acpi-handle-hack/0.0.1
dkms install acpi-handle-hack/0.0.1
echo acpi-handle-hack | sudo tee -a /etc/modules
sudo update-initramfs -u

(had to use http:// instead of git://, in my uni).

How can I apply this "ACPI handle hack" on Ubuntu to solve my BIOS/Lenovo-specific problem and make Bumblebee/Nvidia work?

share|improve this question
add comment

2 Answers 2

https://github.com/Bumblebee-Project/bbswitch/tree/hack-lenovo

https://bugzilla.kernel.org/show_bug.cgi?id=42696

"Until this kernel bug is fixed, you need to apply an ugly hack on these laptops to make bbswitch and the driver (both nouveau and nvidia) work. For now I have decided not to put the hack in the bbswitch module since it is a very ugly hack that is comparable to writing a maximum allowable speed of 130 km/h on a traffic sign for a road where 120 km/h is allowed just because the radar gun does not work properly.

The module has been tested on a Lenovo IdeaPad Y570 running an up-to-date version of Ubuntu 11.10 Oneiric (64-bit) with Bumblebee 3.0 (3.0-1~oneiricppa2) installed using the Nvidia driver."

It seems isn't fixed yet, so you must to try the dirty hack. I have the same notebook, and under Fedora I don't get work the secondary GPU (NVidia Geforce GT555M) because at boot system doesn't recognize VRAM or VBIOS.

Please try the hack from bbswitch or install bumblebee & bbswitch from the official repository and tell us what happens.

share|improve this answer
add comment

If you are on ubuntu, why not use the official bumblebee ppa and install it through apt?

sudo apt-add-repository ppa:bumblebee/stable
#optional for newest nvidia drivers: remove #optional
#optional sudo apt-get purge nvidia-current
#optional sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update 
sudo apt-get install bumblebee bumblebee-nvidia
reboot #important.

Bumblebee troubleshooting:

[ERROR]Cannot access secondary GPU - error: could not start X Server and/or Kernel oops with GT 600M series cards (Kepler)

Make sure you have a recent kernel and the latest nvidia driver, i.e. not only the one, which first claims support for GT600M cards (302.17). First working driver for the tested card (GT620M - inside ASUS UX32) is the (beta) driver 304.22. (tested with kernelversion 3.4.6 on ArchLinux).

To verify this issue, make sure bbswitch cannot be loaded (e.g. move it away) and try: "nvidia-xconfig -query-gpu-info".

If you cannot solve your issue, continue at Reporting Issues.

https://github.com/Bumblebee-Project/Bumblebee/wiki/Troubleshooting

share|improve this answer
1  
Because that isn't enough. The Y570 uses slighty different IDs for the GPU or something, so it always spits out the same error as above. –  Joe Jul 30 '12 at 20:55
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.