Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to use the answer for 166261 question. The suggested package ( install asus-wmi-dkms_0.2_all.deb.gz package (from http://ubuntuforums.org/showpost.php?p=12057336&postcount=49) ) seems not working for me. There is any new package / ppa for asus-wmi-dkms ?

Description of my framework:

===========================================================

Machine: Asus N56V laptop

===========================================================

Software

  • Kubuntu 12.04 amd64

  • kernel linux-image-generic-lts-quantal (3.5.0.9-generic) and drivers from ubuntu-x-swat ppa

===========================================================

Hardware and problems

  • after installation do not boot - SOLVED using boot-repair

  • every couple of hours the system freezes - SOLVED using 3.5 kernel

  • keybord FN keys - PARTIALLY WORKING (using asus-wmi -v 999.01)

  • Keyboard backlight - NOT WORKING

  • Nvidia GEFORCE GT - NOT USED glxgears says 60 fps

  • Ethernet Atheros card - SOLVED install alx driver

  • external subwoofer - SOLVED adding options snd-hda-intel model=asus-mode4

==========================================================

Solutions

see the asnwers to the 162047 and 166261 questions

==========================================================

share|improve this question
    
Since you are using an unsupported, unofficial kernel, this is not surprising. Does the package work/build on the official 3.2.0-27 kernel? –  izx Jul 30 '12 at 19:43
    
well, as stated in the link, the .deb package was intended for the 3.5.0-2-generic kernel. The standard 12.04 kernel creates a lot of problems: all the hardware problems reported above (see the answer to 166261 question). The problem is that I cannot find any asus_wmi package (the only ppa I found is the Keng-Yu lin but it is for oneiric). So my question: is this module included in the kernel? Or it is mantained elsewere? –  Mirto Busico Aug 1 '12 at 15:19
add comment

2 Answers

up vote 2 down vote accepted

The latest Quantal update brings kernel 3.5.0-11 which supports all (except brightness) functionbuttons out of the box. Be sure to remove the dkms module first!

share|improve this answer
    
I'll try asap. Now I have kernel 3.5.0-13-generic from ubuntu-x-swat/q-lts-backport/ –  Mirto Busico Aug 30 '12 at 7:52
    
Users expiriencing crashes and unbootable systems should have a look at: bugs.launchpad.net/ubuntu/+source/linux/+bug/1041883 –  peterrus Aug 30 '12 at 16:36
    
Hi, I've removed the dkms module with "sudo dkms remove --all -m asus-wmi -v 999.01". Then rebooted. All works well, but the FN key for brightness (as you said) and for keyboard backlight didin't work –  Mirto Busico Aug 30 '12 at 17:44
    
You could always file a bugreport for that against the linux-kernel (bugzilla.kernel.org) and it might just get fixed –  peterrus Aug 30 '12 at 21:58
    
Thanks. I'll file a bug this evening when I'll have access to the asus notebook –  Mirto Busico Aug 31 '12 at 7:15
show 1 more comment

0) install quantal kernel headers
1) tar zxvf asus-wmi.tar.gz to /usr/src/
2) sudo dkms build -m asus-wmi -v 999.01
3) sudo dkms install -m asus-wmi -v 999.01

Source: http://ubuntuforums.org/showpost.php?p=12086401&postcount=27

share|improve this answer
    
Done, getting the kernel from ppa:ubuntu-x-swat/q-lts-backport - now the volume fn keys work correctly; but still no keyboard_backligth. A new directory appeared /sys/devices/platform/asus-nb-wmi/leds/asus::kbd_backlight I'm investigating on the content –  Mirto Busico Aug 9 '12 at 17:33
    
Investigating I've seen that /sys/class/leds/asus::kbd_backlight/brightness contains the value 3 - This should indicate that the keyboerd_mackligth is on at the maximum brightness - Still it is not illuminted –  Mirto Busico Aug 9 '12 at 17:46
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.