Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried to download Ubuntu 12.04 through Windows Installer (Wubi), but I get this error message:

An error occurred: Could not retrieve the required disk image For more information, please see the log file: c:\user(username)\adddata\local\temp\wubi-12.04-rev266.log

I tried to locate the file, but I can't find it, it's probably hidden. I know there's already a similar question asked, but I don't understand proxy thing

Downloading error "Could not retrieve the required disk image "

I was wondering will I get this same problem if I download via USB stick or CD?

I'm running Windows 7 on a laptop. I'm not tech-savvy, so I need clear answer please.

share|improve this question

marked as duplicate by Eliah Kagan, Lucio, muru, Tim, Warren Hill Aug 19 at 5:51

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
The log file is in the %TEMP% directory. Part of the path is hidden so you can't navigate step by step unless you set your file view options to show hidden files. This problem could be a network issue or if you're installing Kubuntu (bug) –  bcbc Jul 30 '12 at 18:26
1  
Try downloading the installation image over HTTP(the website) and without renaming it, put it in the same folder as Wubi executable. –  hexafraction Sep 13 '12 at 20:42
    
To me it simply was that I was not connected to Internet. Once I established a connection, it went fine with no error from wubi. –  Bucic Dec 26 '12 at 19:05

3 Answers 3

This seems to be an issue with the wubi version, as described here, which creates incompatibility with the Ubuntu version you are trying to install.

Yes the log file is hidden on this location C:\users\username\appdata\local\temp\ The name of the file is something like "wubi-12.04.1-rev190.log" You have to enable "view hidden folders" on folders options of Windows Explorer.

This problem will not happen if you create a Live-USB or Live-DVD, because wubi is a installer inside Windows. You may try Ubuntu from a Live-USB without any changes to the system, however, given the fact that Wubi provides an easy way to try Ubuntu without partitioning, mess with boot menus and that you may uninstall it later just as easily as uninstalling any other application, here it is something that worked for me.

Try to get wubi installer from here instead: http://releases.ubuntu.com/precise/ It is the wubi.exe located at the bottom of the page.

Then try again the whole process and if everything goes fine this time, wubi will ask you to reboot computer. Do it and check if the option to boot Ubuntu is there.

share|improve this answer

Yahoo I have found another way and a easy way.

  1. locate the file wubi-12.04.1-rev190.log the way its mentioned in the above given way and click the file and press simple delete then you will get an error message telling:

    wubi-12.04.1-rev190.log is opened in pyun.exe"

    or any thing at all.

  2. So open your task manager and go to process and find pyun.exe (in my case ) and click it and "end process"

Now install Linux Wubi as you wish. Well I am not very good in comp stuff but the pro will understand what this means. So pros just have a look at this way.

share|improve this answer

PLEASE READ THE LOG CAREFULLY....actually Wubi is trying to locate some particular file in ISO file (or any source like live-usb,etc) and when it could it gives this error...I too had this problem but after reading the log and comparing it with file in the ISO, I found vmlinuz was missing its file extension(in my case it ".efi"). Wubi was trying to locate "vmlinuz.efi" and it could find it as it was named as vmlinuz. I name renamed the file...every went well then suddenly I got another error and then again I studied the log,now it was a different error. Wubi tried to copy vmlinuz in my installation directory, which now was named as vmlinuz.efi, so I made a copied of "vmliunz.efi" file and renamed back to vmlinuz.

Eureka!! It was successful.

Steps to follow(this is strictly base on study of the log. I woould strongly recommend to read the log and verify every file Wubi is searching)

  • files please go to your casper directory in your installation source
  • make two copies of vmlinuz
  • rename one of them to vmlinuz.efi and leave other as it is.

follow these steps and your are good to go.

ivarbhardwaj

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.