Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Laptop Specs: HP Pavilion G6-2020SE GPUs 1) ATI HD7000 Series 2) Intel Integrated

OS Installed: x) Ubuntu 12.04 (64 bit)

i) ATI Graphics Card Drivers Installed From AMD website. Note: Graphics Card Drivers are Working Fine in 3D Mode. It runs a little Hot as it should since its a GPU.

Observation) AMD Catalyst Control Centre Lets me Choose If I want to run the system in HIGH-END (ATI GPU) OR Intel Integrated (Better battery life)

While I am on High End GPU Choice, Ubuntu works fine.

Problem) But when I switch to Intel Mode in the AMD CCC and reboot the Machine. Ubuntu goes into 'Low Graphics Mode'. The problem is not that it goes into low graphics mode, it is completely expected since I am no longer using the ATI GPU but the integrated Intel GPU. Problem starts with the 'Selection' of the options. During that screen, I have no mouse on the screen (even tried plugging in an external USB mouse) & No Keyboard functionality. Thus I am left completely disabled to choose any option and load into Ubuntu. The Only thing I can do is switch to a terminal and enable ATI GPU through command-line and Ubuntu works Fine again.

Is it a bug that there is no mouse/keyboard available to me during the startup of Ubuntu when its launched in Low-Graphics Mode?

Any suggestions on how to pass through that? My palms are sweating as I write this down because the ATI GPU is really heating up my laptop. I dont want to boot into Windows or keep it around any longer than necessary. Please advise with help and directions.

Sincerely, MonkeyD

Edit1: The Answer by Celso has helped me switch to Intel, thus giving me sufficient battery power. Kudos to Celso. Now I can at least use my laptop for the time being without having it burn hair off my skin.

I am still looking for answer to my original question of, 'why is lightdm not working properly when I switch to Intel GPU using ATI HD7000 series official drivers provided by AMD'.

share|improve this question
    
Please follow the instructions on this page (launchpad.net/~hybrid-graphics-linux) so Linux can support Hybrid-Graphics more efficiently –  Muhammad Gelbana Nov 29 at 15:08

2 Answers 2

On my notebook I have to set the gfx mode in the BIOS. You may want to check whether you have that option.

share|improve this answer
    
I Have no such option to choose my GPU in the BIOS. My BIOS seems to be very very limited in the options. –  Monkey Drone Jul 31 '12 at 0:50
    
Please follow the instructions on this page (launchpad.net/~hybrid-graphics-linux) so Linux can support Hybrid-Graphics more efficiently –  Muhammad Gelbana Nov 29 at 15:13

I am currently using an Acer 3820tg

  • intel core i3 350M
  • 2.26 Ghz L3
  • Ati Mobility Radeon HD 5470 up to 2138 MB hyper memory
  • 13,3" HD LED LCD
  • 4gb DDR3
  • SSD corsair 60GB sata 2
  • And to use my Intel graphics and to disable my ATI card, I need to add a few things.

(I did this in a clean installation and with the open source graphics. You should not install the catalyst drivers since they will remove the vgaswitcheroo option and you will not be able to use it.)


First, edit your Rc/local file:

gksudo gedit /etc/rc.local

then add these lines before the exit0 :

  1. sleep 6
  2. echo ON > /sys/kernel/debug/vgaswitcheroo/switch
  3. echo IGD > /sys/kernel/debug/vgaswitcheroo/switch
  4. echo OFF > /sys/kernel/debug/vgaswitcheroo/switch

Then save and restart. (please note that it worked for me but it may not work for you! use it at your own risk)

share|improve this answer
    
I removed the AMD supplied drivers and I am back to using the Radeon kernel for the ATI card. This turns off the 3D definitely without doing anything by default and gives me a good amount of battery life of a normal laptop. I have very little knowledge of vgaswitcheroo. All I can tell you of now is that fglrx doesn't work. I have no way of knowing if my system is capable of handling 3D rendering. Last I read an article about one week old that said the ATI HD7000 series still have no proper open-source support and it should be there by the end of the year. I will google up vgaswitcheroo. –  Monkey Drone Jul 30 '12 at 18:45
    
I have tried my system without the lines you asked to add and without it. With the lines I am getting 3-4 Hours of battery life as I expect from it. Without the lines I get 1.5 Hours of battery life. Seems like the lines are doing its job perfectly. Now I need to educate myself how to work with vgaswitcheroo so I can switch to full 3D for gaming on linux. Thank You. And If someone still figures out what is going wrong with the original problem with the drivers supplied by ATI themselves. That would be great. –  Monkey Drone Jul 30 '12 at 19:04
    
phoronix.com/scan.php?page=news_item&px=MTEyOTI , as you can read in that artcile. The HD7000 series is far from running smoothly on Ubuntu. –  Monkey Drone Jul 31 '12 at 0:55
    
Please follow the instructions on this page (launchpad.net/~hybrid-graphics-linux) so Linux can support Hybrid-Graphics more efficiently –  Muhammad Gelbana Nov 29 at 15:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.