Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This has been going on for a while now. When there are new updates for Firefox add-ons and I start Firefox it's trying to download them but it fails. E.g. the first extension is Firebug. After a while I get a dialog:

Firefox could not install the file at 

http://releases.mozilla.org/pub/mozilla.org/addons/1843/firebug-1.6.0-fx.xpi

because: Download error
-228

How can I fix this?

share|improve this question
    
It only happens with that plugin? –  t3mujin Dec 11 '10 at 22:01
    
This happens with both Firebug and YSlow. –  Luke Jan 9 '11 at 10:48

3 Answers 3

If the extension is installed via the package manager, you won't be able to download updates. Uninstall it using the package manager, and install from the repository.

The repository doesn't update versions between releases, but security patches are backported. If you have multiple users, you may want to use the repository as all users get the extension. Otherwise, each user (and profile) needs to download and install their own copy.

share|improve this answer

Some bums didn't update the add-on URL correctly.

Get them here manually: ftp://ftp.mozilla.org/pub/mozilla.org/addons/

share|improve this answer
    
as a side note don't install addons through package manger do it through firefox from the above url. –  nelaar Mar 11 '11 at 11:47

Disable ipv6.

  1. Type about:config in the addressbar, press Enter.
  2. Find network.dns.disableIPv6 in the list.
  3. Right-click -> Toggle.
  4. Restart Firefox and try again.

That should fix your problem.

BTW, to avoid confusion, keep in mind your updating an extension, not a plugin. Plugins in Ubuntu are usually installed and updated via repository. Some extensions can also be installed/updated via repository, but most commonly they are downloaded and updated via Mozilla Add-ons site and Firefox Add-ons Manager, which is what you are trying to do.

share|improve this answer
    
To disable ipv6 I assume I need to set it to "false"? If so, it currently already is set to "false". With network.dns.disableIPv6 set to "false" to problem persists. I just had another failed update. Any other ideas? –  Luke Dec 12 '10 at 20:40
    
Check if you are accepting cookies and if network.http.sendRefererHeader is set to 2. Also delete your browser cache. If that doesn't help, then go to the extension page, right-click on the install button and select the option to save it. Then drag the downloaded xpi file to Firefox to install. –  lovinglinux Dec 13 '10 at 12:51
    
If nothing works, add /versions to the extension url, then right-click on the latest version and select the option to save it, then drag the downloaded file to Firefox's window to install. –  lovinglinux Dec 19 '10 at 12:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.