Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to mount a micros sd card with adaptor in ubuntu 12.04 but it will only mount if i lock the adaptor before putting the card in and thus get a read only mounted card. If i do not lock the adaptor before i cannot see the card. In windows i do not have any problem, the card will mount read/write without any problem. Any idea what to do in order to get it working Read/write in ubuntu?

share|improve this question
add comment

6 Answers

I had this same problem not even 5 minutes ago. I was trying to figure it out on the forums and googled it and all. After about 40 minutes of searching I decided to try and log out and log back in while the micro SD card and adapter were in the slot. Once logged in I tried to move my files in and it just worked. I heard somewhere in my searches that linux will try and protect the device if it's removed improperly to prevent data corruption, and the only way to fix it is to restart or log back in. Hope it works for you too!

share|improve this answer
add comment

Following some googling, I found that blowing really hard into the card slot worked. Apperantly dusty cardslots can be responsible.

share|improve this answer
    
This did the trick for me :) –  Gibbs Jan 20 at 16:36
add comment

Maybe to try to remount the device manually with explicitly given option "rw" and look what terminal says?

mount -o rw /dev/your_device /any_directory
share|improve this answer
    
The thing is, since i can only see it with the lock on, whatever i do i cannot chance the rights from read only to write/read. –  Luc Jul 30 '12 at 11:28
    
You mean you have a device with hardware lock ability? I've heard such devices very expensive and supported very poor. –  seeline Jul 30 '12 at 11:38
    
Maybe. You need to look for some unusual driver in the repositories. –  seeline Jul 30 '12 at 11:42
    
here is the thing i am talking about: amazon.fr/Kingston-m%C3%A9moire-microSDHC-adaptateur-Classe/dp/… –  Luc Jul 30 '12 at 11:59
    
Did you check the kernel log? –  seeline Jul 30 '12 at 12:03
show 4 more comments

Possible data corruption

Most probably there is an error in the filesystem of the microSD card, which causes Ubuntu to mount it as readonly (thus saving your data from further corruption).

To verify whether you have a case of data corruption, start

gnome-system-log

and check if you get any corruption messages as soon as you connect the microSD card.

What you should do in this case is to copy the files from the microSD card to your computer and format it again with the Disk Utility. Then, copy the files back to the microSD card.

Filesystem requires administrator access

If you formatted the microSD card using the Disk Utility, you may have chosen the ext4 or other Linux filesystems. In this case, the user ID of the folder in the microSD card might be different from your own user ID.

To verify whether you have a case of wrong user ID, run

gksudo nautilus

and try to copy any file onto the microSD card. If the copy still fails, then you have the data corruption issue (thus, see above). If the copy works, then it is a permission issue with user IDs. You can use this Nautilus file manager to change the ownership of the folders/files on the microSD card. There is an option to Take Ownership in Nautilus.

share|improve this answer
add comment

I've solved a similar problem by assigning a volume name to the Micro-SD card (under Win). After this the problem disappeard under Ubuntu 12.04.

share|improve this answer
add comment

I had a similar problem. I suspect the last file I copied on the SD card got corrupted somehow (probably pulled the the card out too early).

I simply deleted the file using another PC (windows). Re-inserted the card and all is good now.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.