Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using toshiba tecra s1 and it has a problem in ubuntu 12.04 I installed ubuntu with wubi but it says wireless is disabled by hardware switch and I tried to off airplane mode and #rfkill unblock all and fn keys doesn't work, help me

share|improve this question
    
Did you try "$sudo rfkill unblock all" ? try it to type more than 3 times in the terminal. –  Suhaib Sep 30 '12 at 0:26

1 Answer 1

Have you checked the BIOS settings?

I experienced something similar with a Dell laptop that I had just purchased from a friend and had a heck of a time trying to figure out what the problem was. It had Windows 7, which was another first experience for me, at that time and I thought maybe it had something to do with the network settings in the OS. I searched through every settings menu I could find, tore apart the Windows help guide and still could find nothing wrong. Besides, of course, my Wi-Fi being disabled via hardware switch. My Fn key worked for everything else, like suspend and monitor switching, but when I'd use it to try to turn on the Wifi it would just disconnect my wired network leaving Wifi unchanged.

Soon after, I decided to try out DSLinux and while looking through my BIOS I discovered what the OS must've been referring to as the Hardware switch. Ironically, it was on the same page as the USB emulation switch. The LAN controller was on, but the wireless was switched off. I toggled the switch and found that it had three settings; on, off and on/off toggle with Fn key.

Not sure if you've checked this or not as you didn't mention it, but I thought I'd share my experience and hopefully it helps you or another who runs into this problem.

Another idea that just came to me, not sure if this is a possibility or not, but maybe it's disabled in Windows. I'm not sure that'd keep it from being toggled while in Ubuntu or not, but it's worth checking out as well. Good Luck :)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.