Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Yesterday I decided to install Ubuntu 12.04 as I have already installed Windows 7 and want to go for dual boot. The problem is it doesn't shows me the boot menu. This is what I get:

Error: no such partition
grub rescue>

First, I installed it manually and when I saw this message, I started searching for the solution. Tried to fix it many ways - recommended boot repair, manual GRUB2 reinstall, GRUB2 upgrade, ensured that it's in the right dev/sda drive and dev/sda7 partition (in my case), but still the error occurs... Even when I used EasyBCD, I made a Ubuntu boot entry but when I select it, the same happens.

So, I deleted all linux partitions and tried automatically with the alongside option in the installer. The main partition was sda6. Well, it didn't fixed it again. After then I restored the original MBR of win7 and now I'm writing you through it. Here is the boot info script. What am I doing wrong?

Another mess up happened, somehow after the alonside install and after I deleted its linux partitions. Gparted shows that my logical partition(Local Disk D) have bad sectors and it is with extended file system, while Acronis disk director and windows disk manager shows everything is ok and it is as it was before - ntfs file system. There's no any data loss in that partition or problems, maybe its something from GParted?

enter image description here

share|improve this question
add comment

1 Answer

Your Ubuntu partition is far (>100GB) from the start of the disk. You may need a separate /boot partition at the start of your disk. See https://help.ubuntu.com/community/InstallingUbuntuOnBigDisk

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.