Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Ubuntu fails to boot. (It was working fine for the last moth.)

Selecting "recovery mode" shows the message:

fb: conflicting fb hw usage inteldrmfb vs EFI VGA - removing generic driver

However, after this message is shown, the system still does not boot.

share|improve this question

3 Answers 3

  1. Whilst on the GRUB selection screen (where you select your operating system, recovery mode, etc) use the arrow keys to navigate to the normal boot entry, bur rather than pressing enter, press the letter 'e'.
  2. Delete the line gfxmode $linux_gfx_mode
  3. Press F10 to boot

If this doesn't work, try again, but first disconnect all USB devices (other than keyboard!) and extra monitors if you have them.

If you can not reboot, once booted, run the following, so that hopefully you won't have to do the steps above everytime you boot.

sudo grub-install
sudo update-grub
share|improve this answer
1  
[This worked for me, but I have seen different solutions on the internet] –  8128 Jul 30 '12 at 7:29
1  
I've tried this, but my system still doesn't boot. Where are the other solutions you mentioned @fluteflute? –  D4nC00per Jan 31 '13 at 2:29
    
Removing this line did the trick but the change is not saved between reboot even after grub-install and update-grub. I used grub-customizer to edit grub configuration and make the change permanent. –  flm Sep 19 at 15:27

While trying to install linux mint 17, I stuck in the same problem. In my case there was no gfxmode $linux_gfx_mode line in grub so what I did is to add nomodeset BEFORE quiet splash.

Check that http://askubuntu.com/a/207177/34553 for what nomodeset is.

share|improve this answer

I was learning how to use scalpel. A customer dinged up her laptop so I was trying to retrieve some data. Scalpel threw a load of .pgp into the scalpel dir and filled the partition. The box kicked out this very same error.

So before you look for solutions, look at causes. Apparently, it says no when its full.

No room at the in/out. Gparted sda7 into unallocated space from live media. You may have to make some. Not much. Just enough so linux can rm again. 2 more Gb worked.

CtrlaltF1 after clicking your sick OS in the grub menu.

Login at your big new terminal.

Root the pig and delete whatever stuff it was stuffed with.

Worked for me. Kept me up late. Ruined "quality" time w/ the Mrs. Put me behind on a Comp essay. Its not Ubuntu's fault. I let my fat fingers do the stomping.

share|improve this answer
    
Pardon me, It was 2:30 AM, and I'm an old geek. Ctrl+Alt+F1 will get you a terminal prompt after you make a choice in the Grub menu. Not F10, F1. Sorry, Hope it helps. Gary –  Gary Nov 3 at 14:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.