Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'd like to use the Awesome Window Manager with all the other XFCE4 environment daemons, like keyrings, panels, power managers, etc. Is there a way to do this?

share|improve this question

1 Answer 1

up vote 5 down vote accepted

(Tested on Xubuntu 12.04, but with the ppas for Xfce 4.10 and 4.12 installed; however this will work from Xfce 4.8 onwards (default 12.04 version))

You can either run awesome as the window manager in an Xubuntu or Xfce session (which I think is what you want), or run it from its own awesome session (once installed that becomes an option in lightdm).

First install awesome from the repositories with

sudo apt-get install awesome

Now, if you want to run awesome as window manager in an Xfce or Xubuntu session, you can edit the relevant xfconf setting with:

xfconf-query -c xfce4-session -p /sessions/Failsafe/Client0_Command -t string -s "awesome" -a

This command changes the default window manager in the Xfce session to the awesome window manager. With other window managers such as metacity, you would instead use -t string -s "metacity" -t string -s "--replace" -a as the second part of the command. The --replace option is not available or needed anyway with awesome.

Now logout and login again by choosing the normal Xubuntu or Xfce session if you want to run awesome within an Xfce session.

To return to xfwm4 as default window manager, run

xfconf-query -c xfce4-session -p /sessions/Failsafe/Client0_Command -t string -s "xfwm4" -t string -s "--replace" -a

You may need to configure the various options in awesome by creating a personal rc file in $HOME/.config/awesome and tweaking the various options:

mkdir $HOME/.config/awesome
cp /etc/xdg/awesome/rc.lua $HOME/.config/awesome/

You will need to set up your themes and manually tweak how windows will appear, as the normal Xfwm4 window manager settings and tweaks will obviously not work when using awesome.

The screenshot below is of awesome running in a Xubuntu session, with the rest of Xfce still installed. If you have an Xfce panel at the top of the screen it will obscure the awesome panel, so you will have to move it elsewhere.

enter image description here

For more information on awesome and its keybindings, see man awesome and the Ubuntu manpages online.

Note: This does not work at least as of Ubuntu 13.10. Bug report against XFCE4 opened.

share|improve this answer
    
I suspect something is changed, this does not work anymore. I see awesome panel for a second which is then overlapped by xfce4 panel. And everything hangs. Mouse works though. –  Dilawar Jan 14 at 9:02
    
In addition to the steps in the selected answer, you may also need to change the /general/SessionName property from Default to Failsafe. (Tested with switching to the i3 window manager in Xubuntu 14.04.) –  Ryan Koppenhaver Apr 18 at 0:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.