Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I use filezilla so as to access my project's web space at sourceforge.

There is no firewall blocking anything because I can successfully login using the 'sftp' command via a terminal, but I want to use Filezilla, because it is much easier this way to manage your files.

Filezilla used to work fine when I used 11.10, now, when I open Filezilla and fill in the following things:

Host: web.sourceforge.net
Username: Username
Password: Password
Port: 21

And, when I click on the Quickconnect button on the right I immediately get this message:

Status: Resolving address of web.sourceforge.net
Status: Connecting to 216.34.181.70:21...
Status: Connection attempt failed with "ECONNREFUSED - Connection refused by server".
Error:  Could not connect to server
Status: Waiting to retry...

When I go to Edit->Network configuration wizard... I am not sure what to do in order to make it work.

I will just mention what are the current settings I have according to what the configuration wizard says when I open it:

1st page:

Default transfer mode: Passive

Allow fallback to other transfer mode on failure (ticked)

2nd page:

Use the server's external IP address instead

3rd page:

Ask your operating system for the external IP address

Note here: The 3rd option on this page (Get external IP from the following URL) has from default the URL http://ip.filezilla-project.org/ip.php, which, when I open it at my browser, it gives 127.0.0.1 (!) which, obviously, is not correct!

Don't use external IP address on local connections (ticked)

4th page:

Ask operating system for a port.

5th page: (Test results are the following:)

Connecting to probe.filezilla-project.org
Response: 220 FZ router and firewall tester ready
USER FileZilla
Response: 331 Give any password.
PASS 3.5.3
Response: 230 logged on.
Checking for correct external IP address
IP 192.168.1.254 bjc-bgi-b-cfe
Response: 510 Mismatch. Your IP is 6X.X.XXX.XXX, gc-b-cdi-cdh
Wrong external IP address
Connection closed

It is obvious that the local IP address (192.168.1.254) is being sent to sourceforge, which is totally wrong!

Any solution?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

web.sourceforge.net does not support plain FTP (on port 21), only SFTP (i.e. FTP-over-SSH). There really is nothing listening on port 21, hence the ECONNECT error (nothing to do with the external IP).

You need to prefix the URL in QuickConnect with sftp://, i.e. sftp://web.sourceforge.net, and everything works great:

enter image description here

share|improve this answer
    
Thank you very much! That worked perfectly! I didn't need it under 11.10, though, which is weird! –  hakermania Jul 29 '12 at 23:09
    
Perhaps you had a saved profile or something? I don't use Firezilla much, and it has many preferences for fallback, etc. Anyway, glad you got it working! :) –  izx Jul 29 '12 at 23:12
    
No, I used the options I specified on my question and it worked like a charm. After I updated to 12.04 a new updated version of filezilla was available, I think, and, when I filled exactly the same things, it didn't work. Weird. Thanks again. –  hakermania Jul 29 '12 at 23:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.