Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am very new to the OS so adhering the new things slowly but happily. My question is how to transfer folder from win7 NTFS partition to separate partition having ext4 file system? I tried copy but at the destination drive the paste doesn't get activate.

Edit: Here's what i got when typed in the terminal

~$ mount
/dev/sda1 on / type ext4 (rw,errors=remount-ro)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
udev on /dev type devtmpfs (rw,mode=0755)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
none on /run/shm type tmpfs (rw,nosuid,nodev)
/dev/sda5 on /home type ext4 (rw)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
gvfs-fuse-daemon on /home/ramesh/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=ramesh)

I am using the latest LTS edition.

share|improve this question
1  
That probably means you do not have the right permissions to paste the contents on that drive. Can you please open a terminal, type mount and copy and paste the output of that command in to your question? As it is this question cannot be resolved, you need to improve it by adding more information. –  Bruno Pereira Jul 29 '12 at 20:13

3 Answers 3

up vote 0 down vote accepted

Let's step by step

For Example: If you have this scheme:

sda1 = Windows OS, NTFS folder containing the "myDataWin"
sda2 = OS Linux Ext4
sda3 = Ext4 (Partition for target data)
    • You must mount the NTFS partitions and Ext4, for this you must have root privileges.
# mkdir / mnt / WindowsData
# mkdir / mnt / DataFinal
# mount-t ntfs / dev/sda1 / mnt / WindowsData
# mount-t ext4 / dev/sda3 / mnt / DataFinalz

2.- Copy the folder "myDataWin" from the NTFS partition to Ext4 partition

# cp -R / mnt / WindowsData / myDataWin / mnt / DataFinal

That's it.

share|improve this answer
    
easy, since the terminal with root: # fdisk-l or $ sudo fdisk-l You must show this information Device Boot Start End Blocks Id System / dev/sda1 1 12749 102400000 7 HPFS / NTFS / dev/sda2 12749 19123 51200000 83 Linux –  LinuxUser Jul 30 '12 at 2:46
    
Sorry, i can't figure out the path of my ntfs drive as it shows this name under properties 74DA8463DA842388 and on hovering mouse it shows /media/74DA8463DA842388. I actually have the ext4(which should be the destination of the copy operation) as /media/Data. Does that mean both drives are under root? I have 2 separate physical hard drives and source and destination are both from different physical drives. I hope this info could be of some usefulness to guiding me to the right direction –  Ramesh Jul 30 '12 at 3:01
    
1. - This means and partitions are mounted. 2. - To verify this you can run the command: $ df-h This command also informs you about the path of the partition. 3. - You only need to copy from NTFS partition to the partition Destination Ext4. # cp-R / media/74DA8463DA842388/myDataWin / media / Data –  LinuxUser Jul 30 '12 at 3:07
    
ramesh@Ramesh-PC:~$ cp -r /media/74DA8463DA842388/'My Music'/ /media/Data cp: cannot create directory `/media/Data/My Music': Permission denied ***why it says so, i want to copy My Music folder to /media/Data –  Ramesh Jul 30 '12 at 3:21
    
Need privileges for that.$sudo cp -r /media/74DA8463DA842388/'My Music'/ /media/Data –  LinuxUser Jul 30 '12 at 3:22

I suggest trying to paste the file anyway, using [Ctrl] + v. Or drag and drop the file.

I have noticed that in Nautilus the Context menu option "Paste" is greyed out despite having permissions to paste into that location.

This has already been logged as a bug: https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/949468

share|improve this answer

lets do step by step

Better if you are booting from Bootable usb

go to home and just open the both drives once and see if they will appear on desktop

  1. open terminal
  2. type sudo -i
  3. it will ask for password which you have put while installing this system
  4. say your NTFS drive is "alpha" and your ext3 partition name is "linx"
  5. type cd /media
  6. then type ls for listing the folder and drives
  7. say your have install linux mint and you see one folder named mint with cdrom
  8. now type cd mint and then type ls for listing again until you see the both partition from which you want to exchange date
  9. type cd alpha
  10. type cp -r /media/mint/alpha /media/mint/linux

this will copy the all the folders form NTFS to ext3 partition

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.