Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After a fresh install of 10.04, trying to boot yields grub> prompt. I am able to boot by typing

root (hd0,1)
linux /vmlinuz-blqh-blqh root=/dev/sda3
initrd /init-blqh-blq root=/dev/sda3
boot

GRUB says version 1.98. I searched for a menu.lst entry, but turns out that is deprecated. I tried looking ad /etc/defauld/grub and /etc/grub.d, but I cannot make anything of those files.

How do I automate the booting process? My system is single-boot.

share|improve this question

2 Answers 2

up vote 4 down vote accepted

ASsuming you want Ubuntu to run the boot with grub

Get into the system as you have been doing, open a terminal and run thse two commands

sudo grub-install /dev/sda
sudo update-grub

You could try bootrepair tool

https://help.ubuntu.com/community/Boot-Repair

Grub2 wiki is here https://help.ubuntu.com/community/Grub2 but as you have said it's not as simple to deal with as grub legacy was.

share|improve this answer
    
I tried boot-repair, but it seems to be helpless without an internet connection, which I do not have on that box at this time. Also, why is GRUB v 1.98 considered GRUB 2 !?! –  Vorac Jul 29 '12 at 21:19
    
So...simple. I had tried grub-install /dev/sda1 and that didn't work. Could you please explain why your answer works! –  Vorac Jul 29 '12 at 21:33
1  
Grub needs to be in the mbr for it to work as a bootloader. Putting it in the partition only works if that grub can be seen by the system's bootloader - I have 3 or 4 different systems installed at any one time - only one is installed to the MBR - all the others I install grub to their respective partitions - then an update-grub finds them and adds them. Grub2 is the second one - it might actually make it to be v2 in reality - grrub legacy never actually made it to v1 :) –  Elfy Jul 30 '12 at 6:32

Assuming Ubuntu was just installed, it wasn't installed on the drive you think it was. The BIOS sees the Grub installation but the Grub installation isn't looking for the kernel in the right place. I'd change the drive the motherboard thinks its booting from.

Once you get in, whether using this install or a live disc, make sure disk drive references in /etc/fstab use UUIDs. Tracking which drive has which UUID is a drag but makes this sort of debug much easier. IMO.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.