Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've been trying to configure my TV as external monitor, because the only thing I saw on it was a white background with a X as cursor.

I tried around in the nVidia XServer Settings, but I never got it working that it would disable the laptop monitor and move to my TV as soon as I'd plug in the HDMI cable. After not beeing able to get it to work, I tought I'd rename xorg.conf so it would create a default configuration again (at least I tought it would).

After a restart, I got the login screen. I entered my credentials, screen went black for a second, followed by a short sequence of the nvidia logo when it finally threw me back to the login screen. I tried logging in again, but same behaviour.

I quickly booted to the root shell, renamed the old file back to xorg.conf, but it still wouldn't work. I then tried booting into failsafe mode, which told me that he couldn't detect any screens. Bootet up again, went to tty3 console, and tried the following:

sudo service lightdm stop
sudo Xorg -configure

This leads to

Number of created screems dpes mpt ,match number of detected devices.
Configuration failed.
ddxSigGiveUp: CLosing log
Server terminated with error (2). CLosing log file.

Also, I can only selected between Ubuntu and Ubuntu 2D at login, I tought there were some more options? I'm using default Ubuntu 12.04 Desktop.

If you need any log files, please let me know which ones so I can provide them.


Update: I tried this accepted answer. While using gdm I am able to login. As soon as I change it back to lightdm, I can't log in anymore. Any idea?

share|improve this question
up vote 5 down vote accepted

Ok, for some reason, deleting the .Xauthority file did the trick (I can't find the thread again which said that, but it was here on, and I was able to log in again. Unfortunately I already did remove and reinstall so many different components, that I had some strange behaviours (for example new system sounds), that I decided to reinstall.

Edit: This was the thread.

share|improve this answer
thanks for sharing, I was unable to log in after messing around with xorg, and this fixed it! – Jobi Carter Oct 31 '12 at 3:09
@JobiCarter Glad it helped :) – Ahatius Oct 31 '12 at 11:39
At me, nothing in common with the problem. – Gangnus Jun 26 '14 at 10:42

protected by Community Jul 6 '13 at 13:10

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.