Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I intend to use a forked version of unity (ppa:ikarosdev/unity-revamped) over the original one. The problem I'm facing is that the forked version is 5.12.0-0ubuntu3 and the original one is 5.14.0-0ubuntu1.

sudo apt-add-repository ppa:ikarosdev/unity-revamped
    sudo apt-get update
    sudo apt-get upgrade

using the above commands gives me the following output.

Reading package lists... Done
   Building dependency tree       
   Reading state information... Done
   Calculating upgrade... Done
   0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Any help ?


share|improve this question
up vote 3 down vote accepted

I think I have found why it's not working for you. 5.14.0-0ubuntu1 is still in the proposed section of the software repositories. If you disable the proposed selection in the software sources and then run the install commands it should then give you the option of installing unity-revamped

Open the Software Center and in the Edit menu select software sources then click on the updates tab....

enter image description here

Remove the check from the Proposed box.

Then in a terminal run

sudo apt-get update After the update is completed try to run

sudo apt-get dist-upgrade again and it should show you that unity 5.12.0-0ubuntu3 is available.

Just a note, it is safer to not select the Proposed updates unless you need some program that is not available in the current release. The Proposed selection will install as updates all the newest programs, but they are the programs that are still in the testing phase so they can have some bugs still. Once the programs that are in the Proposed section have been fully tested, they will be moved to the Updates section and be available as a stable package.

The untiy-revamped ppa lags behind the release a little bit, I believe that it was about a week the last time but he seems to do a good job of keeping it updated(as far as I can tell anyway, this ppa has only been running a short time)

As an aside, I have been running unity-revamped and have had very few problems with it, the dodge windows feature occasionally sticks and will not hide the launcher but it is fixed by logging out and back in. This only happens once in a great while and everything else works fine while it is stuck....

Edit: the above mentioned version of unity (5.14.0-0ubuntu1) is currently the recent version of unity so 5.14.0-0ubuntu1+ikarosdev2 should install correctly (as of Sept 2012) but this answer will still work if you have the proposed repository selected and are getting a similar error but with different version numbers. i.e. this will occur any time a new version of Unity is installed from the proposed section but the unity-revamped ppa has not bee updated to the newest "proposed" version.

share|improve this answer
@EmersonHsieh sorry to step on your answer, I would have just added this as a comment but it was too complicated to squeeze into a comment... – TrailRider Jul 29 '12 at 19:35
Thankyou TrailRider, your solution worked like a charm!. I first unchecked the Proposed updates in software sources, then had to purge the unity-revamped PPA and added it again. At last updated and upgraded. Thank you, for putting me in the right direction. – Srinivas Gowda Jul 29 '12 at 19:59
glad I could help, your problem threw me for a loop, I had to search for the version of unity you had installed to figure out that it was in the proposed section, then it started to make some sense. – TrailRider Jul 29 '12 at 20:02
I can't thankyou enough for all the trouble you took for finding me a solution. Keep up the awesome work bro. – Srinivas Gowda Jul 30 '12 at 8:34

Replace sudo apt-get upgrade with sudo apt-get dist-upgrade

sudo apt-get upgrade updates installed packages and never installs new packages.

sudo apt-get dist-upgrade updates installed packages, and may install new packages along the way.

share|improve this answer
+1 in fact OmgUbuntu says to use the dist-upgrade command in their instructions on how to install it. – TrailRider Jul 29 '12 at 17:55
I had tried that too, returns with: 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded – Srinivas Gowda Jul 29 '12 at 18:30

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.