Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am a first time user of Ubuntu. I recently installed it as a dualboot with Windows 7. I have Logitech USB speakers which work fine in Windows. However, I can't get any audio to play in Ubuntu. Any help would be appreciated.

Here is an output from the Terminal:

home@ubuntu:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC887 Analog [ALC887 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: AUDIO [USB  AUDIO], device 0: USB Audio [USB Audio]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
share|improve this question
add comment

2 Answers 2

Open system setting then go to sound and under the hardware tab you should find your speakers if you dont know which one to choose then just click test and keep trying you wont ddamage your system.

share|improve this answer
    
I tried all four options, including 'Digital Output (S/PDIF) USB Audio'. None of them worked. I clicked on Test Sound and didn't hear anything from my speakers. I just tried plugging them into the front USB port and they work fine there. Is there a way I can get them to work in the rear port? They work in Windows in the rear port. –  Jack Jul 29 '12 at 15:48
    
Can you find out if your back usb port is version 1, 2 or 3 this might help troubleshoot the issue. –  mark kirby Jul 29 '12 at 15:57
    
I believe it is USB 2.0. –  Jack Jul 29 '12 at 16:17
1  
It's working now. I have four USB ports in the back. I tried plugging in my speakers to different ones and it finally worked. It still doesn't work in the one I had it in originally. But it works in Windows and Ubuntu in the current port so I'm happy. Thanks so much for your help Mark. So far, I'm really liking Ubuntu! –  Jack Jul 29 '12 at 16:35
    
Glad you sorted it out mate. –  mark kirby Jul 29 '12 at 17:12
add comment

Install Veromix. Start the application and select the device you want to use as the default device.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.