Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm currently using Kubuntu 12.04 and after installing nVidia drivers and Setting resolution up to 1440x900 limit, fonts look ugly,only browser content fonts work well, I tried fixing them using Fonts-KDE contol Module, but it didn't work, Please help here is a screenshot enter image description here

share|improve this question

2 Answers 2

up vote 4 down vote accepted
  1. Open KDE Settings Manager

  2. Then go to Application Appearence

  3. Select Fonts section

  4. change the Use anti-alialising option to Enabled

  5. Then click Configure button.

  6. In the new window, select Use subpixel-rendering and change the value to RGB

  7. Change the hinting style to Slight.

  8. Then remove the file .fonts.conf in your home folder. It is a hidden file. To see, that file in Kubuntu, Press Alt + . .

    Here is a screenshot of the settings window

    enter image description here

  9. Logout and Login again.

share|improve this answer
    
That helped, but Helvetica and Roboto (default fonts in G+ and Facebook) still look like a dog's breakfast. –  Paul Tomblin May 25 at 19:03
    
Oh never mind, I had the "Exclude Range" checked. Unchecking that fixed everything! –  Paul Tomblin May 25 at 19:06

In your home folder, rename .fonts.conf to .fonts.conf.bak then log out. Log back in and the fonts in Firefox are good to go.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.