Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

For a while I have the problem mentioned in the title. Update is stuck on pre-configuring packages without any other error. I tried almost everything I've found searching Google, but it didn't solve my problem.

btw

sudo apt-get update
sudo apt-get autoclean
sudo apt-get clean
sudo apt-get autoremove
sudo apt-get update && sudo apt-get upgrade

is not working. Can somebody please help me fix this issue?

share|improve this question

1 Answer 1

I noticed that a mysql process was starting every time I tried to upgrade and it was eating all of one of my processors. That same process stopped after I stopped the upgrade process. I was unable to determine the cause of that mysql process being stuck so I followed the advice from here: MySQL fails to start after upgrade to 12.04?.

Then, after running apt-get upgrade it worked without a problem.

Hope this helps.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.