Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Recently bought a new laptop (Samsung 700Z) and installed ubuntu 12.04. Most stuff works out of the box, but some details are driving me crazy. I installed the fglrx driver to shut down the fans and also the samsung-tools, so I can change the fan behaviour. But:

Keys for the keyboard backlight do not work also they are mapped in /lib/udev/rules.d/95-keymap.rules. The cd ejection key does not work. Keyboard and screen backlight settings are not stored, so after each reboot, suspend and even screen locks both backlights are set to maximum.

Using acpi_backlight=vendor in grub does not fix that behaviour, it makes it even worse: I cannot set the screen backlight to high values, just about to 30 percent of the possible max. Any help would be very appreciated!

share|improve this question
    
making the eject key work should be really easy. Go to 'System Settings' -> 'Keyboard' -> 'Shortcuts'. In the tab Sound & Media there should be an entry 'eject' just click on it and press your eject button. –  Daniel Jul 29 '12 at 12:18
    
There is the correct key added. Seems that the problem was a corrupt dvd. –  Christian Jul 29 '12 at 12:26
add comment

2 Answers

Finally I got it to work. I had to write various scripts and wrote the story down here: http://blog.christian-hufgard.de/keyboardscreen_backlight_settings_ubuntu_12_04-2012-07-30

share|improve this answer
    
Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Eliah Kagan Jul 31 '12 at 0:06
add comment

In most laptops now a days those settings won't get stored. Its because of different hybrid solutions and proprietary graphics drivers. Follow the followings to set it to moderate brightness at start up.

Try following for paths shown by ls /sys/class/backlight/*/brightness and replace accordingly.

example paths will be like

/sys/class/backlight/acpi_video0/brightness
  1. For the above path Get the maximum brightness:

cat /sys/class/backlight/acpi_video0/max_brightness

Try a lower value to set the brightness, say output is 16 so I will try with half of it

echo 8 | sudo tee /sys/class/backlight/acpi_video0/brightness

If there are more than one path, repeat the above steps to see which one gives you more flexibility.

If this works, make this happen in each login automatically by doing the following

sudo gedit /etc/rc.local

Enter this line just before exit 0. It should look like

echo YOUR_VALUE_HERE > /sys/class/backlight/acpi_video0/brightness
exit 0
share|improve this answer
    
As far as I know, rc.local is only called during startup. I added a script under pm-utils/sleep.d and this was executed during resume. But even this does not resolve the problem that a locking of the screen sets all values to maximum. :( –  Christian Jul 29 '12 at 12:28
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.