Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

If I run pulseaudio as a nonroot user (for example mpd starts it with user "mpd" or I start it with my user), random noises arises when I try to start or pause, change the volumes, or switching tracks.

I also got random noises if I transfer sounds from my notebook to this pulseaudio server, for example, from vlc. If I run pulseaudio from a root user, noises are absent, but mpd can't connect to this pulseaudio server and I have no music player.

share|improve this question
    
Do you have the same problem when running mpd as your logged on user? –  aquaherd Jul 29 '12 at 14:47
    
Thank you for response! I start mpd at startup on ubuntu server 12.04. I set in /etc/mpd.conf to start it as usual user. I think this problem is not mpd, because in mocp I have similar effect. If I set mpd to use as audio output clear alsa I have no this problem, but in my system for some reason only root have access to alsa volume managing (I forced to set mpd start as root to be able to manage volume level) although user is present in audio group. –  Pupizoid Jul 29 '12 at 17:26

1 Answer 1

Seems problem solved with restoring default config /etc/pulse/default.pa and editing only 3 lines for transferring sound:

### Network access (may be configured with paprefs, so leave this commented
### here if you plan to use paprefs)
load-module module-esound-protocol-tcp auth-ip-acl=127.0.0.1;192.168.1.0/16
load-module module-native-protocol-tcp auth-ip-acl=127.0.0.1;192.168.1.0/16
load-module module-zeroconf-publish

Thanx for trying to help.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.