Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have bought a new Dell Inspiron N4010 laptop with Windows 7 installed. I have installed Ubuntu via Wubi. I am using a BSNL Broadband connection with a ZXDSL 831A11 modem.

Internet is working fine in Windows 7. But after logging into Ubuntu, I am not able to get an internet connection. There is no eth0 connection active. And my network card is : Atheros AR8152 PCI-E Fast Ethernet Controller

Some more info by googling : http://www.downloadatoz.com/driver/articles/download-atheros-ar8152-fast-ethernet-controller-driver-for-dell-laptops.html

Any way to obtain this driver for Ubuntu?

share|improve this question
    
is your modem connected via USB oder viva LAN (RJ45) to the notebook? –  aatdark Dec 11 '10 at 14:48
    
Are you using network manager for connecting internet?Post the output of ifconfig -a and cat /etc/network/interfaces in pastebin and give the link. –  karthick87 Dec 11 '10 at 14:51
    
via LAN.. And my network card is : Atheros AR8152 PCI-E Fast Ethernet Controller.. –  Sen Dec 11 '10 at 15:07
    
@Karthick: yup.. i tried looking into ifconfig.. it just showed lo, it dint have eth0.. The same in the Network Manager.. –  Sen Dec 11 '10 at 15:10
    
Feels like this Ethernet card is not supported by Ubuntu..:-( –  Sen Dec 11 '10 at 15:11

2 Answers 2

up vote 3 down vote accepted

Answered at http://ubuntuforums.org/showthread.php?p=9449490, #6 likely solution steps. Dell 4010 Atheros wired ethernet driver not in kernel 10.04 64.

share|improve this answer
    
Dint work.. installation was success.. but network dint come up.. still ifconfig -a displays only lo.. –  Sen Dec 11 '10 at 16:58
    
on a second reboot it was working fine.. –  Sen Dec 11 '10 at 17:30

This is a guess so please update your question if you try this and it doesn't work but it worked for this person with a similar card so maybe we'll get lucky and the updated wireless driver will pull in one for the NIC.

Install linux-backports-modules-wireless-lucid-generic Install linux-backports-modules-wireless-lucid-generic and then reboot and try it.

share|improve this answer
    
could not install linux-backports-modules-wireless-lucid-generic.. Dependency issue.. –  Sen Dec 11 '10 at 16:57
    
@Sen Please add the error information to your question. –  Jorge Castro Dec 11 '10 at 17:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.