Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am so stumped and 2 days into trying get Ubuntu on this machine, Lenovo Z570.

Initially installed 32-bit 12.04 and it worked fine except it only acknowledged 2.9GB RAM (should be 8NG), which is when I learned that I was supposed to have installed the 64-bit version. Did so, can't boot up.

Error is PXE-E61 Media test failed, check cable (booting from HD as it should be).

"Boot-repair" (installed under Live USB) hangs on scanning, never completes. If I close it manually a few screens come up and I can try the Recommended Repairs but no fix.

It looks like there was a BIOS update for this machine but it is only for Windows and that has been gone since first Ubuntu install. I have tried reinstalling 32-bit, it does work, so have ruled out a cable actually being unplugged.

What should I do?

share|improve this question

1 Answer 1

Okay, much headdesk later, Ubuntu 64 12.04 is running. For anyone else who needs to install on z570, here are some notes:

  • Run the BIOS update, this must be done through Windows as they are supplied as exe's from Lenovo. Unless you are a Linux ninja and can do it from the Live CD (I am not!). If you already let Ubuntu completely overwrite your HD then you'd better get a Windows iso and make that update run.

  • When going to reinstall, Ubuntu did not see my Windows partitions, just 100% unallocated space. There is something wrong with the partition tables and unless you know how those things all work, it is far more painless to let Ubuntu just repartition your whole drive. FixParts reported that my partitions were all overlapping one another. I did a bit of tweaking and eventually Gparted (and LiveCD install process) could see my partitions but still no success in installing to the designated ext4 formatted one.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.