Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

Trying to install skype on Ubuntu 12, I faced and issue. When I type:

sudo apt-get update
sudo apt-get install skype

I get an error

Reading package lists... Done
Building dependency tree       
Reading state information... Done
skype is already the newest version.
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 skype : Depends: lib32stdc++6 (>= 4.1.1-21) but it is not going to be installed
         Depends: lib32asound2 (> 1.0.14) but it is not going to be installed
         Depends: ia32-libs but it is not going to be installed
         Depends: libc6-i386 (>= 2.7-1) but it is not going to be installed
         Depends: lib32gcc1 (>= 1:4.1.1-21+ia32.libs.1.19) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

How do I solve it? Is the way I'm using the right one to install skype?

UPDATE: If I try to do

sudo apt-get install lib32stdc++6 lib32asound2 ia32-libs libc6-i386 lib32gcc1 skype

then I get

Reading package lists... Done
Building dependency tree       
Reading state information... Done
skype is already the newest version.
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 ia32-libs : Depends: ia32-libs-multiarch
 lib32asound2 : Depends: libasound2 (= 1.0.25-1ubuntu10)
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
share|improve this question

marked as duplicate by Eliah Kagan, Luis Alvarado 13 hours ago

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2  
i think u already install skype, bqz it says skype is already the newest version., look at application menu –  geoh Jul 28 '12 at 17:14
    
I have the same issue here with 12.10 x64, I get the same error, looks like its a packaging issue as Skype installs fine on 12.10 x32. –  Arup Roy Chowdhury Oct 19 '12 at 15:13
    
When it says use "apt-get -f install" do not append skype in the end e.g "apt-get -f install skype" won't work. This applicable to other applications as well. –  Malay Desai Mar 7 at 9:10
add comment

6 Answers 6

up vote 3 down vote accepted

Your dependencies are broken even though skype is installed. run this command:

sudo apt-get install -f

This should help to fix the broken dependancies

share|improve this answer
add comment

Use only sudo apt-get install -f to install.

share|improve this answer
add comment

according to the errors listed , Skype is already installed , the above are dependency errors .

You need to install ia32-libs-multiarch by

sudo apt-get install ia32-libs-multiarch 

then try your method method

share|improve this answer
    
ya, but the problem is with 32 bit libs, it can't be installed, come to chat room chat.stackexchange.com/rooms/4288/… –  geoh Jul 28 '12 at 17:59
add comment

Maybe type:

sudo apt-get install lib32stdc++6 lib32asound2 ia32-libs libc6-i386 lib32gcc1 skype

EDIT Try typing:

sudo apt-get install -f skype
share|improve this answer
1  
Unfortunately it doesn't help me. –  Alex Malex Jul 28 '12 at 17:07
    
what output it gived? @AlexMaslakov –  geoh Jul 28 '12 at 17:08
    
Look at my update –  Alex Malex Jul 28 '12 at 17:09
    
@AlexMaslakov ok, saw, look at updated answer –  geoh Jul 28 '12 at 17:10
    
The result is equal to the first error. –  Alex Malex Jul 28 '12 at 17:15
show 2 more comments

This will do the trick :)

sudo apt-add-repository "deb http://archive.canonical.com/ $(lsb_release -sc) partner"
sudo apt-get update && sudo apt-get install skype

Found on: http://www.ubuntugeek.com/how-to-install-skype-in-ubuntu-12-04precise.html

share|improve this answer
add comment

I'm New. Try install UBUNTU TWEAK.

enter image description here

Hope it help.

share|improve this answer
add comment

protected by Community yesterday

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.