Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've got Ubuntu 12.04 running on this Dell XPS 14 Ultrabook (L421X). Everything is working but my wireless transfer rates are low. I'm getting about 1MB/s download speed on the ultrabook vs 15MB/s on the E6500.

If I move into the room with the access point the speed climbs to 15MB/s so I'm guessing it is a signal strength issue but wavemon shows comparable signals to those seen by the E6500.

Are there any settings I can tweak in hopes of making it faster?

share|improve this question
add comment

3 Answers

up vote 0 down vote accepted

I had the same trouble, but not on Ubuntu -- the wifi card pulled 25-50% of what my least capable wifi device could squeeze out of my 20Mbps connection. I got a new system through customer support, and the card worked much better. Then, I upgraded my router (I picked up a new Netgear 600, the white one designed to like Macs and PCs) for $99. That fixed the problem.

Good luck -- I know the feeling of running and re-running that speed test! And for what it's worth, once this machine is running right it's a real joy.

share|improve this answer
    
Thanks. I'll get our Dell service guy to check it out. –  GaryBishop Aug 4 '12 at 21:17
    
Is your problem solved now? I'm getting Dell XPS 14 Ultrabook on Amazon. I see the latest driver was from October 24,2012. Is it fixed your wireless issue? –  Cuong Thai Nov 25 '12 at 9:04
    
Yes, solved by the new router. I like the laptop. The touchpad is annoyingly sensitive. –  GaryBishop Nov 27 '12 at 0:10
add comment

This is advice from rodpott on another forum posting that helped my wife's XPS14z get much better reception. (I swapped nano for vi, but gedit may be best for most)

sudo vi /usr/lib/pm-utils/power.d/wireless

search for

iwl*) if [ -f "/sys/class/net/$1/device/power_level" ]; then
iwlevel_ac=0
iwlevel_batt=3

and change it to:

iwl*) if [ -f "/sys/class/net/$1/device/power_level" ]; then
iwlevel_ac=0
iwlevel_batt=0

Also, there is an issue with something called CAM and improper adherence to the standard in many routers. SOURCE That may be why a new router solved the issue.

share|improve this answer
add comment

I know nothing about Ubuntu, however, I do have a 14z and have along history with the WiFi problems on it. Hence the reason I had a Google news alert setup which fed me your post. There's a number of posts in the Dell forums on the subject, which might come down to a bad design of the laptop. Dell has replaced my card twice and my antenna twice, then finally actually down graded the WiFi card to a 6300 (no bluetooth) to see if that would help. Kinda ticks me off that I don't have bluetooth now, but I'm still int he process of sorting it out with Dell and they have been nothing but great about everything. This card seems to be working better than the OEM card (6330, I think), but still not as good as my iPad sitting right next to it.

Some tricks (again, knowing nothing about Ubuntu) you might try:

  • Turn off laptop battery power saving setting which puts card in low performance during low battery.
  • Replace drivers with Intel's OEM card drivers.
  • Enable Intel connection settings and mess with the options thereunder.

Best of luck. Oh, I guess I'd also suggest opening a support ticket to document the problem from the start.

share|improve this answer
add comment

protected by Community Oct 8 '12 at 13:59

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.