Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

So, the only thing I can think of is that Ubuntu did not correctly install some software as it doesn't recognize .run files. I checked "allow to run as executable file", but nothing.

share|improve this question

marked as duplicate by karel, chaskes, Warren Hill, Seth, Eric Carvalho Nov 17 '13 at 1:20

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer 1

.run files are usually scripts. You can open them with text editor to see what is inside. In most cases, double clicking them should either run, or prompt asking you whether to run.

If the GUI does not provide an option to run them,

  • Open a terminal ( Shortcut Ctrl+Alt+T )
  • Change directory. Type cd /path/to/file and hit Enter
  • ls -l <file-name>.run and see the output.
    • If you dont see a 'x' in the first collumn, Type chmod +x <file-name>.run and hit Enter
    • If you see something like -rwxrwxr-x , skip to next step.
      This is to check if the file is executable, and make it if it is not.
  • Type ./<file-name>.run and hit Enter
share|improve this answer
    
when I use the ls -l <file-name>.run it shows verbatim: -rwxrwxrwx 1 zerik zerik 58529488 I follow using chmod +x, and it still says "cannot execute binary file –  user79882 Jul 29 '12 at 2:32
    
The file has proper permissions set. The problem must be elsewhere. We need more information on what file this is, to help you. –  Mahesh Jul 29 '12 at 3:50

Not the answer you're looking for? Browse other questions tagged or ask your own question.