Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

These are some useful specs:

  • Macbook Pro 7,1
  • OWC Mercury Extreme Pro 2,5" SATA SSD (120 GB). Has SandForce driver.
  • Ubuntu 12.04 Desktop 32 bits.
  • One 18 GB partition for GNU/Linux and 1.5 GB for SWAP.
  • MD5 for the Ubuntu install CD is OK.

I tried to install Ubuntu. It seems that everything is recognized, but there's a big problem: read and writes to the SSD are extremely slow. For example, the install process, which shouldn't take more than 20 minutes, it takes 7 hours. Then, booting up the computer takes about 20 minutes. I checked and the problem is definitely the SSD. Every access to any file is like 10 times slower than normal.

I have tried to format the partition as Ext4 and Ext3 with the same problem.

Trying to install other distros like Fedora 17, I have a similar problem. There's a "lag" with the SSD, but not so accused as in Ubuntu. Surprisingly, Debian 6.0 installs and works without any problem. Mac OS works pretty good as well in the other partition, so I discard it's an SSD problem.

Thanks for your help!

share|improve this question

There is an article on the Gentoo Wiki that describes an issue with a BIOS compatibility mode potentially slowing down SSD access.

When MacBook uses BIOS compatibility mode, it switches the SATA controller to IDE mode, making hdd/ssd operations slower since kernel will use ata_piix module insetead of ahci. It seems there are couple of ways to change this, but this one I find to be the easiest, and actually it is the only that worked for me. I have tested this with MacBook Pro 6.2.

It doesn't sound like it's on the scale you're talking about, but still perhaps something to check.

share|improve this answer
Thanks, but this doesn't solve the problem. – Menda Jul 28 '12 at 19:51

I might have had a very similar problem (MBP 7,1, SSD: OCZ Vertex 2). I checked my SSD performance using sudo hdparm -tT /dev/sda and sometimes (not reproducible) got values <1 MB/s (!). The installation (Ubuntu 12.04 32bit, 64bit) took very, very long and updating the system lasted forever. As OS X was very fast I thought it was something else than the SSD. So I tried ext3, ext4 - same behaviour. Finally I upgraded the SSDs firmware (which was pain in the *#~ as the OS X tools that OCZ provides do not run as they should) and that did the job! Have you tried updating your SSD?

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.