Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Network manager cannot connect to a wifi, if the wifi is password protected (WEP or WPA). However it can connect to passwordless wifis. Also, I can conned to password protected wifis manually as:

sudo service network-manager stop
sudo iwconfig eth1 essid "<WIFI-NAME>" key s:<WIFI-PASSPHRASE>
sudo dhclient eth1

But it would be nice to get the network manager working again. Any suggestions where to look for the cause of this problem?

The network manager does see the wifi, but then it just keeps forever trying to connect, never succesfully. I also tried installing an alternative manager, wicd, and it has the same problem, looks like it gets stuck to trying to get IP, never succeeds.

After update to 12.04 and trying several desktop environments (finally settling to xfce), I removed KDE, Gnome3 and Ubuntu desktop following these advice:

Maybe those removed some (maybe dhcp-related) component, that is causing my problem, but this is just a guess.

EDIT: As I said, I also tried with WICD, and it gets stuck in exactly same way.

share|improve this question
up vote 0 down vote accepted

Whatever this was, upgrading 12.04 -> 12.10 fixed the problem.

share|improve this answer

Try using WICD - Taken from this thread: Alternative to Network Manager for wireless?

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.