Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

this sounds like a pretty dumb question but how can I get audio output on headphones and speakers? My motherboard is GA-G41M-Combo and doesn't seem to have any digital audio out, but 3 miniplugs coloured blue, green, and red. I don't want surround, I just want headphones and speakers working at the same time without needing to switch a cable (my headphones have a power on/off toggle). The motherboard looks like this:

enter image description here

I currently have speakers plugged into green (working) and headphones plugged into blue (no sound), and can't seem to get output on the headphones after fiddling with the sound settings in Ubuntu 12.04. Do I really have to buy a splitter?! The motherboard didn't come with any front panel adapters.

share|improve this question
add comment

1 Answer 1

I don't have a system which I can test this out on, but I believe this section from the Arch Linux PulseAudio website should help you:

https://wiki.archlinux.org/index.php/PulseAudio/Examples#Splitting_front.2Frear

To sum up what you should do:

  1. Open a terminal and make a back up of /etc/pulse/default.pa like this: cp /etc/pulse/default.pa ~/default.pa.bak
  2. Open the sound settings menu and change "analog output"'s mode to "Analog Surround 4.0 Output"
  3. In the terminal run pacmd list-sinks and copy the outputted sink's name. Mine looks like "name: ", and we're interested in the bit in <>, yours should now end in "analog-surround-40".
  4. Open default.pa as administrator using sudo gedit /etc/pulse/default.pa and add the lines:

    load-module module-remap-sink sink_name=speakers remix=no master=alsa_output.pci-0000_05_00.0.analog-surround-40 channels=2 master_channel_map=front-left,front-right channel_map=front-left,front-right

    load-module module-remap-sink sink_name=headphones remix=no master=alsa_output.pci-0000_05_00.0.analog-surround-40 channels=2 master_channel_map=rear-left,rear-right channel_map=front-left,front-right

Replace "master=alsa_output.pci-0000_05_00.0.analog-surround-40" with the device name you found in step 3.

Now you should be able to select from "Headphones" and "Speakers" in the Sound Settings menu when you want to switch between headphones and speakers.

share|improve this answer
    
thanks .. it looked promising, and i get two new devices appearing called "Remapped Built-in Audio Analogue Surround 4.0", but there is no place on any device to select between headphones and speakers. in fact, when i select the remapped device the connector: combo box disappears completely (?!) –  wim Aug 4 '12 at 3:02
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.