Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
Tab completion doesn't work for commands

The installed packages prompt is working fine, eg, gedtab completes to gedit, but package autocomplete on apt-get is not showing list of matching packages, like, sudo apt-get install gedtab won't try to fit ged* packages as it normally should. Similarly, quicklytab pops files and folders in the current directory instead of prompting "commands , create, etc".
Any way of correcting this? And yes, I'm on Ubuntu 12.04.

share|improve this question

marked as duplicate by Gilles, Bruno Pereira Jul 28 '12 at 16:25

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer 1

up vote 0 down vote accepted

this must work

  1. Open Terminal (to start Ctrl+Alt+T)

    sudo apt-get remove bash-completion && apt-get install bash-completion

  2. Either edit the ~/.bash_profile file to enable it only for a given user or edit /etc/profile to add it system-wide(using gedit). Add the following code:

    if [ -f /etc/bash_completion ]; then
    . /etc/bash_completion
    fi

taken from http://www.howtoforge.com/how-to-add-bash-completion-in-debian

share|improve this answer
    
had to put the line in /etc/bash.bashrc, and worked, Thanks :) –  piyush Jul 28 '12 at 11:06
    
@piyush youre welcome....! –  geoh Jul 28 '12 at 11:09

Not the answer you're looking for? Browse other questions tagged or ask your own question.