Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a bunch of files in the Documents folder. When I update most of them they are alright, However there is an xhb file (used by HomeBank) which creates some sort of other file *.xhb~. Ubuntu One sees this file and immediately starts hashing it although it is a temporary file which gets deleted. It then drives up my cpu usage until I kill Ubuntu One and start it again. Help please.

2010-12-11 09:35:55,673 - ubuntuone.SyncDaemon.sync - INFO - T:NONE:F 86b46f4f-2c65-4583-9590-af191d790cc7 ['56c92c0f-a5ae-4960-a5a6-61252ba2acd0'::'e6027d46-3d52-44a6-be8b-93421ce5c0c5'] ''Documents/Praveen.xhb~.UOMKNV'' | Called calculate_hash (In: T:NONE:F)
2010-12-11 09:35:55,675 - ubuntuone.SyncDaemon.sync - INFO - T:NONE:F 86b46f4f-2c65-4583-9590-af191d790cc7 ['56c92c0f-a5ae-4960-a5a6-61252ba2acd0'::'e6027d46-3d52-44a6-be8b-93421ce5c0c5'] ''Documents/Praveen.xhb~.UOMKNV'' | Calling calculate_hash (got HQ_HASH_ERROR:{})
2010-12-11 09:35:55,676 - ubuntuone.SyncDaemon.sync - INFO - T:NONE:F 86b46f4f-2c65-4583-9590-af191d790cc7 ['56c92c0f-a5ae-4960-a5a6-61252ba2acd0'::'e6027d46-3d52-44a6-be8b-93421ce5c0c5'] ''Documents/Praveen.xhb~.UOMKNV'' | Called calculate_hash (In: T:NONE:F)
2010-12-11 09:35:55,677 - ubuntuone.SyncDaemon.sync - INFO - T:NONE:F 86b46f4f-2c65-4583-9590-af191d790cc7 ['56c92c0f-a5ae-4960-a5a6-61252ba2acd0'::'e6027d46-3d52-44a6-be8b-93421ce5c0c5'] ''Documents/Praveen.xhb~.UOMKNV'' | Calling calculate_hash (got HQ_HASH_ERROR:{})
2010-12-11 09:35:55,678 - ubuntuone.SyncDaemon.sync - INFO - T:NONE:F 86b46f4f-2c65-4583-9590-af191d790cc7 ['56c92c0f-a5ae-4960-a5a6-61252ba2acd0'::'e6027d46-3d52-44a6-be8b-93421ce5c0c5'] ''Documents/Praveen.xhb~.UOMKNV'' | Called calculate_hash (In: T:NONE:F)
share|improve this question
add comment

1 Answer 1

Ok. First, please reproduce this one more time, file a bug, and attach the complete logfile from where you got the above excerpt; syncdaemon shouldn't go loopy if a file disappears while it's being hashed. You can make the bug private if you don't want everybody seeing that file (or you can email me the logfile if you'd rather).

Then, edit /etc/default/xdg/ubuntuone/syncdaemon.conf, find the bit that looks like

ignore.default = \A#.*\Z
                 \A.*~\Z
                 \A.*\.py[oc]\Z
                 \A.*\.sw[nopx]\Z
                 \A.*\.swpx\Z
                 \A\..*\.tmp\Z

and add a (similarly indented) line with the pattern \.xhb~\.. That should make syncdaemon completely ignore the file. If that works (if it's not that pattern, it's one similar to it), file a second bug asking for this to be included in that setting by default. Please let me know the bug numbers of both.

share|improve this answer
    
Hi Chipaca. I have actually changed the syncdaemon.conf before and added \A.*~*\Z to the list of ignore.default. As you can see the temp file created is Praveen.xhb~.UOMKNV but the last few characters always change when i save the file. After i did that the normal Praveen.xhb file would not sync anymore. Is this the right regex.I am not strong in regex (let alone python regex). I think there are 2 bugs in launchpad bugs.launchpad.net/ubuntuone-client/+bug/461974 and bugs.launchpad.net/ubuntu/+source/ubuntuone-client/+bug/580855 –  Praveen Dec 12 '10 at 4:10
    
tried \A.xhb~\.*\Z but still no luck –  Praveen Dec 12 '10 at 4:34
    
You want either \.xhb~\. (no \A nor \Z) or \A.*\.xhb~\..*\Z; the catch-all regex would be just ~ (or \A.*~.*\Z). –  Chipaca Dec 12 '10 at 18:20
    
perfect. thank you. –  Praveen Dec 13 '10 at 13:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.