Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I run Ubuntu 12.04 dual boot with windows 7 on my Dell Inspiron N4110.My internet speed is very slow on my Ubuntu.My ethernet speed is 100 Mb/s.But,I am getting only 10 Mb/s.This is really annoying me.My laptop has Realtek RTL8111E Gigabit Ethernet Controller on board(found on dell website).I have googled it and found there are known issues with realtek RTL8111 ethernet card.I decided to download the driver from Realtek.

The output of lspci -v command

Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 05)
Subsystem: Dell Device 04d7
Flags: bus master, fast devsel, latency 0, IRQ 46
I/O ports at 2000 [size=256]
Memory at d0404000 (64-bit, prefetchable) [size=4K]
Memory at d0400000 (64-bit, prefetchable) [size=16K]
Capabilities: <access denied>
Kernel driver in use: r8169
Kernel modules: r8169

This output shows the network card is RTL8101E/RTL8102E PCI Express Fast Ethernet controller and In Windows,It is Realtek RTL8111E Gigabit Ethernet Controller.Are these both same.which one should I download.

I never had an issue with 11.10.... Help

share|improve this question
Maybe this: "How can I install the Realtek RTL8111E version 8168 driver?" helps. – BuZZ-dEE Jan 25 '13 at 10:59

I'm having similar problems with an RTL8111E card on my network. I'm wondering if its the cause of an issue I'm having.

The network consists of:

  • windows 7 machine (an alienware laptop).
  • Ubuntu 12.04 desktop, with gigabyte GA-Z68P-DS3 motherboard with an onboard Realtek RTL8111E.
  • Desktop with an onboard gigabyte card, which the laptop connects to with no major issues (also using windows 7).

The card can be forced into gigabit mode using ethtool but then the performance drops markedly. When in 100MBps full duplex I get iperf speeds of 99.4 MBps (as expected). When I switch it to 1000MBps mode it drops to 3.

Now I've used Cat 6 and Cat 5E cables, swapped the cables over, tried connecting over the wireless from the laptop instead and get the same issues of the performance dropping markedly on switching to gigabit mode.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.