Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When you put the Ubuntu 12.04 Live CD/Install CD in and start the computer, instead of saying "Press any key to boot from disk.........." and going to hard drive boot upon no key press, which is what happens with other disks, it automatically starts the disc. How does this happen? What's going on?

share|improve this question

2 Answers 2

Check your boot device priority first. Is it set to CD-ROM? If not, change it.

  • Turn on your computer and enter your BIOS setup (by pressing the special key for that, often Del or F2).
  • Change the first boot device to CD-ROM.
  • Restart.
share|improve this answer

This message is not related to BIOS, but it's what Windows boot disk use.

What I mean is that BIOS hands the control to any bootable CD the same way it does to a Hard Disk. Windows CDs then, by themselves, show this message, and if you hit any key boot from the hard disk.

If you build a custom Windows CD (with nlite) you can disable this prompt.

In short: Ubuntu does nothing to the BIOS, this message is a Windows thing.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.