Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Ubuntu 12.04 32-bit, stock install with minimal additional software

I'm trying to get a multiseat X setup going... two separate keyboard/mouse/monitor sets on one PC. I used this document for guidance, and though I had to install KDM and a bunch of other KDE stuff (tried to accomplish this with lightdm but didn't get anywhere), I'm so close to getting this working.

The monitors and the mice are working correctly, which is to say I get two separate X login screens, and each mouse works a different screen. I also have one keyboard properly working one screen, but where it falls down is that the other keyboard (kbd_0) works both screens. I can't tell where in my config it's going wrong. Any help would be appreciated.

/etc/X11/xorg.conf

/etc/kde4/kdm/kdmrc

lspci

/proc/bus/input/devices

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

After some digging through /var/log/Xorg.?.log, I discovered that both screens were for some reason loading the appropriate keyboard, and then later loading kdb_0. The relevant section was:

[     3.666] (==) ModulePath set to "/usr/lib/i386-linux-gnu/xorg/extra-modules,/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules"
[     3.666] (==) |-->Input Device "kbd_0"
[     3.666] (==) |-->Input Device "<default keyboard>"
[     3.666] (==) The core pointer device wasn't specified explicitly in the layout.
        Using the first mouse device.
[     3.666] (==) The core keyboard device wasn't specified explicitly in the layout.
        Using the default keyboard configuration.

The reference to the "core keyboard" jogged something in my memory. Referring to one of the failed xorg.conf attempts while I was trying to get lightdm to work, I made modifications to both InputDevice lines of both ServerLayout sections:

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice "kbd_0" "CoreKeyboard"
    InputDevice "mouse_0" "CorePointer"
    Option      "AutoEnableDevices"     "false"
    Option      "AutoAddDevices"        "false"
    Option      "AllowEmptyInput"       "true"
EndSection

Section "ServerLayout"
    Identifier     "Layout1"
    Screen      0  "Screen1" 0 0
    InputDevice "kbd_1" "CoreKeyboard"
    InputDevice "mouse_1" "CorePointer"
    Option      "AutoEnableDevices"     "false"
    Option      "AutoAddDevices"        "false"
    Option      "AllowEmptyInput"       "true"
EndSection

After rebooting, the second kdb_0 load is gone from both logs, and the whole setup is working properly.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.