Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Byobu looks very broken in PuTTY. I've already fixed the key mapping issue, but this issue isn't specified in the man page or even Google:

Broken PuTTY Console

Notice the misplaced position of the list of windows, the broken selector position, the duplication of the last window, the random a in the top right, and the misplaced apply option. You can't see this, but the last option is not selectable.

Is there some option in PuTTY I need to use in order to see this correctly?

share|improve this question
    
If someone wants to create the putty tag, that would be nice –  TheLQ Dec 10 '10 at 23:48
    
I don't have Windows anymore, so I can't test, but I would look into the charset settings of PuTTY. –  JanC Dec 11 '10 at 2:27
1  
Screen is great - you just need to have a decent .screenrc –  Marco Ceppi Dec 11 '10 at 17:55

4 Answers 4

Configure putty to read utf8. putty -> config -> window -> translation choose utf in "Recieved data in ..." This is not a byobu issue, it is a putty issue.

See also:

share|improve this answer
1  
Agreed. Note that this is specified in the byobu.1 manpage. –  Dustin Kirkland Feb 22 '12 at 15:46

Related to Putty, I added this note to the byobu(1) manpage a while back:

> PuTTY  users have reported that the
> F2, F3, and F4 shortcut keys are not
> working properly.  PuTTY sends the
> same escape sequences as the linux
> console for F1-F4 by default.  You can
> fix this problem in the PuTTY config,
> Terminal -> Keyboard -> Function keys:
> Xterm R6.

See:

share|improve this answer
    
I've already done that to make Byobu at least usable. –  TheLQ Jan 11 '11 at 20:41
    
Just to confirm what I said above for anyone else who comes along: I meant that the screenshot above is with putty in Xterm R6 mode. So this isn't a fix for this problem. –  TheLQ Jan 19 '11 at 2:05

Ubuntu uses UTF-8 for its terminal, but byobu appears to use the "ISO-8859-1 (Western European)" charset for it menus. You can set the charset in Window -> Translation.

I've found the following code on the Internet, and I'm still happy with it. byobu might have more options, but I like this as well (~/.screenrc):

startup_message off
hardstatus alwayslastline
hardstatus string '%{= kG}[ %{G}%H %{g}][%= %{=kw}%?%-Lw%?%{r}(%{W}%n*%f%t%?(%u)%?%{r})%{w}%?%+Lw%?%?%= %{g}][%{B}%Y-%m-%d %{W}%c %{g}]%{w} %l'
shelltitle "$ |bash"
termcapinfo xterm ti@:te@
altscreen on

Note: for byobu, shelltitle "$ |bash" must be removed / commented, otherwise byobu won't work.

share|improve this answer
    
Putty seems to default to ISO-8859-1:1998 (Latin-1, West Europe), so thats not the issue. Switching to UTF-8 made the terminal extremely slow but fixed the menu. What is that code supposed to do though? Didn't change anything in byobu –  TheLQ Dec 11 '10 at 15:00
    
By default, screen provides you just a shell with multiple (invisible) tabs. With that code, you can have a fancy shell, with on the bottom a (colored) bar like [ computername ][ 0$ bash 1-$ bash (2*$bash) ][2010-12-11 16:24 ] 1.30 1.40 1.43. –  Lekensteyn Dec 11 '10 at 15:25

So for byobu to look good in putty you should actually make two changes.

First is change your keyboard to xterm-R6 as already mentioned, but second, on your linux machine run the command as your normal user: byobu-select-backend and then choose the option screen (usually 2).

Should work great now! Enjoy!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.