Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

So I installed Ubuntu 12.04 LTS 64-bit using the DVD. I followed LinuxBSDos guide for dual booting Windows 7 (first installed) and Ubuntu 12.04 (second install) on 2 Separate Hard drives.

I had Windows 7 Pro installed on /dev/sda1. I installed Ubuntu on /dev/sdb/ (I created separate partitions for root, home, boot, swap following that linuxbsdos guide).

I boot into Ubuntu fine, but cannot boot into Windows 7.

Here is what I've tried so far:

  1. Ran Boot-Repair and did Recommended Repair, but it said you need a Bios Boot partition and I should use Gparted. (Bootinfo summary:
  2. Tried to do a Windows recovery cd repair using bootrec.exe /FixMbr and /FixBoot. (When I did FixBoot, I got element not found error).
  3. Tried to install grub-2.00 onto /dev/sdb/ following this guide:

Error Message:

warning: this GPT partition label contains no BIOS Boot Partition; embedding won't be possible.
/usr/sbin/grub-bios-setup: warning: Embedding is not possible.  GRUB can only be installed in this setup by using blocklists.  However, blocklists are UNRELIABLE and their use is discouraged..
/usr/sbin/grub-bios-setup: error: will not proceed with blocklists.

So I'm at a loss at this point on what to do?

I know I have GRUB on /dev/sde/, that is a 3rd SSD that had Fedora 17 on it, but I had a lot of problems using it so I wanted to switch to Ubuntu for school purposes. I intend to format /dev/sde/ and use it in Windows.

share|improve this question

closed as too localized by Alvar, Thomas Ward, Basharat Sialvi, Mitch, Eric Carvalho Jun 16 '13 at 1:44

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

Have you tried using Windows Boot Repair after giving /boot flag to Windows partition? – farukdgn Jul 27 '12 at 23:58
Tried update-grub, nothing boots now, just a blinking cursor. – zamb1esaurus Jul 28 '12 at 0:08
I should add this motherboard is the asus rampage iv extreme, with uefi boot – zamb1esaurus Jul 28 '12 at 0:09
while booting , Select the Boot From option ( same as CD or USB when you install new OS) , then boot from the Windows Hard Drive . – atenz Jul 28 '12 at 6:45

Have You tried : update-grub ?

So let me get this straight:

Ubuntu = /dev/sdb

Windows = /dev/sda1

Old Fedora = /dev/sde

Try: grub-install /dev/sdb

Then in BIOS in Boot Section select /dev/sdb as first and then /dev/sda1 as secondary boot option

share|improve this answer
I'm stuck at a blinking cursor now, can't boot into anything – zamb1esaurus Jul 28 '12 at 0:13
Can I do this from the Ubuntu DVD? I can't boot into Ubuntu anymore after I did the update-grub option – zamb1esaurus Jul 28 '12 at 0:16
Yes, You can do it from LiveCD. – zuberuber Jul 28 '12 at 0:19
Hey thanks, but I can't even boot anymore to cd, it just freezes. I'm going to have to do a full wipe and reinstall windows – zamb1esaurus Jul 28 '12 at 0:22
Check in BIOS to boot CD-rom first – zuberuber Jul 28 '12 at 0:26

BEFORE YOU WIPE IT! Use your windows boot disk to repair your files, it can still save you, it could be a corrupt MBR (Master Boot Record) that allows your computer to boot into an operating system.

share|improve this answer
  1. Fix Windows via a Windows disk, until you get direct access to Windows.
  2. via Gparted, create a BIOS-Boot partition on the Ubuntu disk
  3. then use Boot-Repair to recover the GRUB menu
share|improve this answer

You need Ubuntu 12.04 livecd for repairing grub boot loader . Here assuming the Ubuntu partition is sda7,and /boot partition is sda6 . Boot up ubuntu from the livecd,open terminal and run:

sudo -i
mount /dev/sda7 /mnt
mount /dev/sda6 /mnt/boot

#skip last one from above if not have a separate /boot partition

grub-install --root-directory=/mnt/ /dev/sda
mount --bind /proc /mnt/proc
mount --bind /dev /mnt/dev
mount --bind /sys /mnt/sys
chroot /mnt update-grub
umount /mnt/sys
umount /mnt/dev
umount /mnt/proc

This will solve your problem.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.