Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

gtk-recordMyDesktop outputs .ogv files that seem perfectly fine - they work well in Totem and VLC. However, if I try to edit them in openshot or kdenlive, the editor either crashes (kdenlive) or won't show the video properly (openshot). PiTiVi appears to work but then locks up when it tries to render the video.

Using video conversion tools, such as ffmpeg outputs a video that is a jumble of colours; although it is just about possible to make out some movement. alt text

The only way I've managed to edit the videos is to use DeVeDe to create a DVD .iso, mount the ISO and then edit the .VOB file(s).

This is a bit of a faff; does anyone know of a better way around this?

share|improve this question
You could try to convert it with vlc since it knows how to play it, and be sure to set the frame-rate when converting. – LassePoulsen Aug 8 '10 at 22:34
There is now a bug report about this issue – dv3500ea Jan 22 '11 at 19:19
up vote 7 down vote accepted

You need to convert them first... they never worked without converting (at least for me):

mencoder -idx out.ogv -o out.avi -oac mp3lame -ovc lavc

Then you can edit them in your favourite video editor (I for one prefer Avidemux).

share|improve this answer
Thanks, that mencoder command works. – dv3500ea Aug 24 '10 at 14:20
This works for short videos. But, mencoder fails with "Too many audio packets in the buffer: (4096 in X bytes)." on long videos (for various values of X). Is there any way around it? – rgrig Sep 6 '12 at 9:22
After failing with ffmpeg and avconv, I tried memcoder which unfortunately also fails ("Too many audio packets in the buffer"). This answer should not be marked as accepted, it is not a solution to this problem. – Luís de Sousa Aug 31 '14 at 14:09
Even with a short video, this mencoder method fails on my Ubuntu 14.04 with the error "Could not open codec. FATAL: Cannot initialize video driver." Using aconv as mentioned in however worked for me. – gene_wood Feb 3 at 23:42

I see you had trouble with ffmpeg, but I have had a lot of good luck converting just about anything using it. If you don't specify a bitrate or quality setting in ffmpeg, it can use some really low quality settings. This may be why your conversions look so crummy. The video editors are picky about what kinds of videos they work well with, so I always convert to MP4 with MPEG4 video and FAAC audio. The command I use is:

ffmpeg -i in.ogv -vcodec mpeg4 -acodec libfaac -sameq out.mp4

The -sameq option tells ffmpeg to try to make the resulting video approximately as good looking as the original.

Once you have it in MP4, I recommend you use OpenShot to edit it.

share|improve this answer
I still get the same problem with the poor quality. It is possibly slightly better, as you can make out shapes but it is still really bad (see the image I have uploaded). – dv3500ea Aug 23 '10 at 15:54
It may be a problem with the codecs you have installed. I recommend adding the Medibuntu repositories because they have better codecs. For help with adding them, visit – brousch Oct 11 '10 at 12:55
You can also try specifying a bitrate to take ffmpeg's guessing out of the equation. Try something like: ffmepg -i in.ogv -vcodec mpeg4 -b 5M -acodec libfaac -ab 192k -r 48000 out.mp4 – brousch Oct 11 '10 at 12:56
On Ubuntu 14.04 this command fails with the following error messages: "Option 'sameq' was removed. If you are looking for an option to preserve the quality (which is not what -sameq was for), use -qscale 0 or an equivalent quality factor option. Failed to set value '1' for option 'sameq' Error parsing global options: Invalid argument" – Luís de Sousa Aug 31 '14 at 14:11

Try lives, LiVES is a Video Editing System, it's available from the repositories.

share|improve this answer
This is really a comment, not an answer to the question. Please use "add comment" to leave feedback for the author. – Mitch Aug 21 '12 at 7:37
Since this doesn't include any information about how to use LiVES after installing it, or why it is helpful for this particular task, I am inclined to agree with Mitch that this might be more suitable as a comment. However, we should be cautious before asking that such answers be converted to comments. And of course, @JoãoPinto, the best thing would be if this answer could be expanded, at least slightly, to particularize it to the needs of this OP. – Eliah Kagan Sep 1 '12 at 3:34
Actually, of every software referenced in this thread, LiVES is the only one able to cope with the ogv files produced by RecordMyDesktop on Ubuntu 14.04. Unfortunately, the user interface is quite awkward and difficult to use. Also, LiVES seems to always crash when saving mpg files. – Luís de Sousa Aug 31 '14 at 15:11
LiVES is no longer able to open ogv files created by RecordMyDesktop. I am presently using version 0.3.8. – Luís de Sousa Oct 11 '14 at 17:56

You can try mobile media converter (.deb download)

Its a great tool to convert videos in good/high qualities then you can edit the video easily using any editor.

share|improve this answer
Isn't that just a frontend for ffmpeg like WinFF? surely it will have all of the same benefits and problems as ffmpeg so I will have the same problem. – dv3500ea Aug 24 '10 at 11:15

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.