Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In my PC, I can watch youtube videos without any problem. However, they lag so much on fullscreen, that it's basically impossible to watch them. How can I fix this?

share|improve this question
    
Related: askubuntu.com/questions/325431/… –  Joren Sep 22 '13 at 22:35
add comment

8 Answers 8

Had the same problem.

Then I realised Chrome already Flash player built in.

I had also installed the Flash player manually so they were apparently interfering with each other. I just disabled the built in Flash in Chrome and voilla. No lag anymore in full screen.

Hope it helps someone.

share|improve this answer
add comment

You should check your about:gpu section in Chrome/ium. In older PC's HW Acceleration is disabled by default and you only can enable it by overriding the settings in the about:flags.

  • Open the about:flags in your address bar
  • Look for Override software redendering list
  • Click "Enable"
  • Restart Chrome/ium
share|improve this answer
add comment

This happens to me as well, specially on my older PC, if I watch a youtube video in fullscreen, it lags. What I usually do is to stretch the screen, but not to fullsize or I play it on VLC Player, where it does not lag anymore in full-screen.

To play a Youtube video on VLC Player, copy the address (if you are using secure "https" connection, remove the "s", make sure the link is http://www.youtube.com/watch). Then go to File -> Open Network Stream and paste in the main YouTube URL for a video.

Unfortunatelly this only works with youtube videos for me, Vimeo videos don't play on VLC.

share|improve this answer
add comment

Tried turning down the resolution on the player? Normally, it will automatically up it when you go to fullscreen.

Other than that non-fix, all I can do is feel with you. If internet is running already, then the drivers are at the best they can be. I've found that Ubuntu is just slower than Windows when it comes to wireless Internet.

share|improve this answer
add comment

Not long time ago there was extension for Firefox named Flash-Aid but it's deleted now. Try to find some similar extension/software.

share|improve this answer
add comment

My cable company (Time Warner Cable in the US) throttles youtube. I blocked the IP addresses associated with the throttling (206.111.0.0/16)

iptables -I FORWARD -s 192.168.1.0/24 -d 206.111.0.0/16 -j REJECT

with sudo (where 192.168.1.0/24 is my LAN subnet).

See the (reddit source) in order to find out what IP addresses are doing the throttling.

You can also check your youtube dl speeds with http://youtube.com/my_speed

share|improve this answer
add comment

Today I struggled with the same question, and I managed to fix it. What I did was, I browsed to the file /etc/adobe/mms.cfg (if it doesn't exist, create it) and I added the line OverrideGPUValidation=true to it.

I then restarted my computer and the lag was gone, both on Firefox and Chrome. No 3rd party applications needed.

share|improve this answer
add comment

I have solved using youtube HTML5 video player.

You can enable HTML5 video player using the following page: http://www.youtube.com/html5

Now videos are fast and the laf was gone. I have tested it on Chrome.

share|improve this answer
1  
This is not a solution but a workaround –  Joren Sep 22 '13 at 22:44
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.