Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have got a laptop and i would like to correct gamma color on my external screen.

My system: Laptop, VGA port, Linux, Ubuntu.

In option System->Preferences->Monitor i turn off my laptop's screen.

But bash-command xgamma -gamma 5 does not any effect. BTW on laptop is (if it will turn on) too.

How can i get it?

share|improve this question

2 Answers 2

up vote 2 down vote accepted

Try adjusting it with the xrandr command.

First find your device name by entering:

xrandr

There's an output line like:

LVDS connected 1440x900+0+0 (normal left inverted right x axis y axis) 367mm x 230mm

You'll have to determine which choice is your external monitor.

The enter a command like (substituting for your device LVDS):

xrandr --output LVDS --prop --verbose --gamma 1.0:1.0:1.5

experiment with value, until you like the results. The numbesr must be floating point and they stand for red:green:blue.

The driver shouldn't matter.

See this man page.

share|improve this answer
    
Thank you "John S Gruber" and "Mik". Sorry for delay. –  Nwbie Aug 27 '12 at 16:30

If you have more than one screen, you have to select the one you want xgamma to target. Check your screens with echo $DISPLAY. The result for my single screen is :0.0. So if I wanted to target my screen I would use :0.0 (even though with one screen it is unnecessary), and thus enter the following: xgamma -display :0.0 -gamma 1.2.

So with this information in mind, turn off your laptop screen, simply find what display number your external screen is using with echo $DISPLAY , and include that in the xgamma command that I have given above.

If that does not solve it, and if you are running proprietary drivers from Nvidia or AMD, you may need to look at the settings and options of those devices rather than xgamma.

share|improve this answer
    
Thank you my friend. But when i turn off laptop screen $DISPLAY is ":0.0" too :( Other combination (from my mind) does not work too. And i can not target xgamma correct. What is wrong? –  Nwbie Jul 27 '12 at 20:28
    
Well, yes when there is only one screen $DISPLAY will be :0.0, so with the laptop screen off, did you try xgamma -display :0.0 -gamma 1.2 If that doesn't work you may have to look at some of the settings for your graphic drivers-are you using proprietary ones? –  user76204 Jul 27 '12 at 20:40
    
Thank you. $DISPLAY is ":0.0" in both cases (laptop & external is on and latop is off & external is on). Command "xgamma -display :0.0 -gamma 1.2" does not effect at all. My hardware is Lenovo x201 with video adapter "Intel GMA HD". Its driver goes from Ubuntu 10.10. How can i know the correct address of my external screen and correct its gamma? ;/ –  Nwbie Jul 27 '12 at 21:05
    
Correct text: Command "xgamma -display :0.0 -gamma 1.2" does not effect at last case. But at first case is work obviously. –  Nwbie Jul 27 '12 at 21:13
    
If it was an Nvidia or AMD card I would say look at the driver settings, but with it being an Intel device I'm not sure what else we could try beyond experimenting with the display values. –  user76204 Jul 27 '12 at 21:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.