Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Ubuntu 12.04 on HP 6930p and every time I reboot the system brightness control goes to back to some default value irrespective of the previous session. I've gone through the earlier posts which suggests changing the following..

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"
GRUB_CMDLINE_LINUX="acpi_osi=Linux"

This doesn't work for me.

any thoughts?

share|improve this question
1  
possible duplicate of Desktop doesn't remember brightness settings after a reboot –  Web-E Jul 27 '12 at 19:14
add comment

3 Answers

I have Ubuntu 12.04 on an ASUS A53z laptop with Radeon HD6520G Video. My brightness keys work, but the brightness is always maxed on boot and I've been looking for a solution for a while. Setting the brightness at boot manually can get tiresome.

I found a small program called xbacklight that works on my system. It might not work on yours, but its worth a try. It uses percentage values, i.e. 20 = 20% brightness, and it does have a man page. If its not already installed on the system you can get it through apt get or synaptic.

Run the program in a terminal with no command line and it will report the current brightness setting as a percentage. xbacklight -set 50, will set 50% brightness.

If the program works for you, put it in the Startup Applications and it will run at each boot.

share|improve this answer
add comment

Try this:

Desktop doesn't remember brightness settings after a reboot

share|improve this answer
    
Mine is a Intel and tried editing /etc/rc.local with the following. The actual desired brightness value is added as 2336483. Didn't work. Tried # exit 0. Didn't work. #!/bin/sh -e # # rc.local # # This script is executed at the end of each multiuser runlevel. # Make sure that the script will "exit 0" on success or any other # value on error. # # In order to enable or disable this script just change the execution # bits. # # By default this script does nothing. echo 2336483 > /sys/class/backlight/intel_backlight/brightness exit 0 –  Bala Jul 28 '12 at 6:08
    
Some of the tricks in the above link works- only on the very first boot. After that it goes back to the default value! –  Bala Jul 28 '12 at 17:05
add comment

Mine is Intel and tried editing /etc/rc.local with the following.

The actual desired brightness value is added as 2336483. Didn't work. Tried # exit 0. Didn't work.

echo 2336483 > /sys/class/backlight/intel_backlight/brightness
share|improve this answer
    
Welcome to Ask Ubuntu! This seems like it might be, at least in part, an answer to the question, but it's worded as though you're asking a separate, related question. To make this clearer for people searching for help (so they know this post might help them), and to decrease the likelihood that this post will be considered not-an-answer and deleted, I recommend rewording this, and also removing anything that is actually a question (rather than a proposed solution) and posting it as a new question. –  Eliah Kagan Aug 1 '12 at 6:58
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.