Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The wireless card is not working but the Internet is working good with Ethernet cable.

The output of lspci is :

02:00.0 Network controller: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller (rev 01)

At fist the card was working but sometimes it's disconnected, and have problem on coverage range, and sometimes it's not working at all

I tried many solutions on the Internet but now it's not working at all.

I don't know what to do :(

share|improve this question
add comment

1 Answer

This forum post seems to have helped most people facing this issue.

I have reproduced the necessary steps here for the sake of simplicity.


In the Additional Drivers application, check for any drivers pertaining to STA and disable them.

Open Terminal and enter the following command:

sudo apt-get remove b43-fwcutter broadcom-sta-common broadcom-sta-source firmware-b43-installer firmware-b43-lpphy-installer firmware-b43legacy-installer bcmwl-kernel-source

Now, enter the following commands:

echo "blacklist bcma" | sudo tee -a /etc/modprobe.d/blacklist.conf
echo "blacklist brcm80211" | sudo tee -a /etc/modprobe.d/blacklist.conf

Reboot Ubuntu.

Open Terminal again and enter the following command:

sudo apt-get install bcmwl-kernel-source broadcom-sta-common broadcom-sta-source firmware-b43-installer

After the package installation is complete, reboot.

Open Additional Drivers.

Enable the Broadcom STA driver.

Your Wifi should now be active and functional.


This seems to be a documented bug.

share|improve this answer
    
thx for your effort –  mohamed ibrahim Jul 28 '12 at 14:44
    
This seems to mostly work, but I don't alway see the broadcom driver listed in the "Additional drivers" I have two HP laptops. My Pavilion G and my wife's Mini 10. Her's shows nothing in "Additional drivers" except something about "Cedar" but following all the other steps seems to get everything working. –  Skip Huffman Oct 11 '12 at 21:34
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.