Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Google Talk/Skype will not transmit my voice. My microphone works in sound recorder, and i can see levels moving when I check sound settings in gmail.

How do I fix this

share|improve this question
2  
If I'm not mistaken, Skype has a setting that automatically adjusts your volume levels. –  Cumulus007 Jul 29 '12 at 21:50
1  
I see that it does. And that has solved my problem. Thank you. –  Fawkes5 Jul 29 '12 at 21:58
    
I think the question im more interested in now is why do i have to put one channel to zero and the other to something else? –  Fawkes5 Jul 29 '12 at 21:59
add comment

2 Answers 2

up vote 7 down vote accepted

This solution solved my problem:

1) Install Pulseaudio Volume Control

2) Go to Input Devices Tab

3) Make Left[Right] channel zero and Right[Left] channel non-zero. Adjust it to suit yourself.

Now everything works.

However, Skype and google talk have auto-adjust features that are turned on by default. These will turn the channel you set to 0 to something non-zero and nothing will work any more. So you have to turn these off.

In Skype, go to options, sound devices and uncheck "Allow Skype to automatically adjust my mixer levels".

Google talk is more complicated as there is no box to uncheck. The following will do it,

1) use your favourite text editor to edit the file ~/.config/google-googletalkplugin/options

2) Change the value of audio-flags to 1

Restart your computer and that should do it

Hope that helped

share|improve this answer
add comment

Setting up PulseAudio

Download: Skype Free Download for linux lastest version

To use PulseAudio with Skype:

  1. Download and install the pavucontrol package. In Ubuntu, select Applications > Ubuntu Software Center. In the navigation pane on the left, select Get Software > Provided by Ubuntu. Search for PulseAudio Volume Control from within the Software Centre and then click to select it. Click Install.

  2. Open the PulseAudio Volume Control and check that the microphone/recording input for your microphone is enabled in the audio mixer settings. Check that your hardware settings are correct in both the Input and Output tabs.

  3. Check that Skype is using PulseAudio. Sign in to Skype. Click Main Menu in the bottom left corner of the application and select Options > Sound Devices. Make a test call.

If you need to adjust the PulseAudio settings, click Open PulseAudio Volume Control to open pavucontrol again and alter as necessary. When you are finished, click Playback to check that all is in order

Disabling PulseAudio

  1. Select Applications > Accessories > Terminal. Type the following and press Enter: gedit ~/.pulse/client.conf The file will open in a text editor.

  2. Type the following: autospawn=no Select File > Save and then Close. Select File > Exit if the document is still open. In Terminal, press Enter to complete the changes.

  3. Stop the PulseAudio process by selecting System > Administration > System Monitor. In the Processes tab, select the pulseaudio process and click End Process. Confirm End Process in the dialog box.

  4. Restart Skype.

Setting up ALSA

To use ALSA with Skype:

  1. Make sure that you have disabled PulseAudio. Sign in to Skype and select Main Menu > Options > Sound Devices. Your devices are set to the system defaults, which should be fine for Skype to work correctly. To change these settings, click a drop-down list and select another device.

    Note: remember to click Apply after doing so for the changes to take place:

  2. Check that ALSA is correctly configured by clicking Make a test sound and Make a test call.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.