Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

i wanted to install php5 5.3.2, so first deleted all the php5 files

 sudo apt-get purge php5 php5-cli php5-common php5-mysql 

and also delete the deb files form

/var/cache/apt/archives

so now there is no deb file on the system then i add this person repository

sudo apt-add-repository ppa:sushkov/personal

because he add php5.3.2 and then i updated it and upgraded it

sudo apt-get update && sudo apt-get upgrade

then i installed php5

sudo apt-get install php5 php5-cli php5-common php5-mysql 

now when i check the php version it says php5.3.10

and when i run this command

sudo apt-cache show php5

it says

Package: php5
Version: 5.3.15-1~dotdeb.0
Architecture: all
Maintainer: Guillaume Plessis <gui@dotdeb.org>
Installed-Size: 0
Depends: libapache2-mod-php5 (>= 5.3.15-1~dotdeb.0) | libapache2-mod-php5filter (>= 5.3.15-1~dotdeb.0) | php5-cgi (>= 5.3.15-1~dotdeb.0) | php5-fpm (>= 5.3.15-1~dotdeb.0), php5-common (>= 5.3.15-1~dotdeb.0)
Filename: dists/squeeze/php5/binary-i386/php5_5.3.15-1~dotdeb.0_all.deb

now i dont know how to downgrade, is there any way that i change something in the repository and write

sudo apt-get install php5 

it will install php5.3.2 which i want instead of php5.3.10

Thanks

share|improve this question
    
Are you talking about the version 5.3.2 that was available in Ubuntu 10.04 –  atenz Jul 27 '12 at 14:41
add comment

3 Answers 3

First make sure that you remove any php reference. Just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, run the command below.

To remove package and config files

sudo apt-get --purge remove <Package Name>

To remove unused dependencies and config files

sudo apt-get --purge autoremove

Download php5 5.3.10-1ubuntu3.2 from Here. Once downloaded, navigate to the folder where the file was saved, probably Downloads, and run the following command:

sudo dpkg -i < package name>

Or use GDebi. To install it press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, run the command below:

sudo apt-get install gdebi

Or click below

Once you have installed GDebi, use the File Browser to find the package you wish to install, and double click on it.

share|improve this answer
    
Sorry i need php5 5.3.2 not 5.3.10 and still when i download this, the package gives error, it opens in ubuntu software center. –  iori Jul 27 '12 at 14:58
    
Its available Here. Download the All arch deb package –  Mitch Jul 27 '12 at 15:17
add comment

According to ppa:sushkov/personal page , the PPA is available only till Ubuntu 10.04 and NOT for Ubuntu 12.04 so even if you add the PPA it will give you error as

W: Failed to fetch http://ppa.launchpad.net/sushkov/personal/ubuntu/dists/precise/main/source/Sources  404  Not Found

W: Failed to fetch http://ppa.launchpad.net/sushkov/personal/ubuntu/dists/precise/main/binary-amd64/Packages  404  Not Found

W: Failed to fetch http://ppa.launchpad.net/sushkov/personal/ubuntu/dists/precise/main/binary-i386/Packages  404  Not Found

And if you are still eager to get the 5.3.2 version , download it manually from PPA package builds page , by expanding the arrow key as

enter image description here

Well , it is HIGHLY RECOMMENDED to use the updated Package version 5.3.10 Available through Official Repository for Security reasons.

EDIT : Download all the packages ending with i386.deb since your system seems to be 32-bit and run the following command from the downloaded directory

sudo dpkg -i *.deb

Also he provided a all.deb file at the end try installing it first then follow the above command.

If you want to compile from source package first install build-essential if not present through

sudo apt-get install build-essential

then download php5_5.3.2.orig.tar.gz then unpack or extract it and run from the extracted directory

./configure && make && sudo make install

P.S. : May not work at all , since two years old release .

share|improve this answer
    
Ok thankx, but is there a way to have one deb file instead of i download all there files and then install it –  iori Jul 27 '12 at 15:03
    
Thanks, if this dont work, where can i get php source for ubuntu so that i can compile it and run myself, but i dont know how to compile it can you also provide me link, that wil be helpfull –  iori Jul 27 '12 at 15:44
    
@iori - See answer , edited. –  atenz Jul 27 '12 at 16:03
add comment

Firstly I would really discourage you from using severaly outdated version of PHP full of security bugs.

And to answer your sort of hidden question – you have manually added dotdeb repository which provides more recent version of PHP5, so you need to remove it from your apt sources. Look into /etc/apt/sources.list.d/.

Also I would like to show you the command you might find usefull in such situations:

$ apt-cache policy php5
php5:
  Installed: (none)
  Candidate: 5.4.4-13
  Version table:
     5.4.4-13 0
        500 http://ftp.cz.debian.org/debian/ wheezy/main amd64 Packages

It will show you the available versions and install candidates together with the package sources in case there are more versions available.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.