Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I try to install my printer using the following command:

hp-setup 10.2.1.99

As you might expect my printer has the IP 10.2.1.99. It is a HP Color LaserJet 2700n.

Everything works well until the very last step when I have chosen the PPD file and clicked Add Printer. I then get prompted with a box where I can write Username and Password, and the text:

You do not have permission to add a printer

I've tried entering credentials to all accounts I can think of that exists in our office, but it does not seem to work.

If I press cancel when prompted, I get this text in the console:

Printer queue setup failed. Could not connect to CUPS Server. Is user added to "lpadmin" group(s)

What permission is it that I need?

share|improve this question

migrated from unix.stackexchange.com Jul 27 '12 at 13:15

This question came from our site for users of Linux, FreeBSD and other Un*x-like operating systems..

    
It might be requesting Admin credentials (root name and password). Have you tried that? –  Kevdog777 Jul 27 '12 at 10:29
    
Yes i have done that. –  Marcus Johansson Jul 27 '12 at 10:39

1 Answer 1

Add your user to the lp user group. Use the following command to accomplish the task:

# gpasswd -a [user] lp

Read the ArchWiki article on Users and Groups for more information on how Groups are used for access to certain system hardware.

Turns out there are multiple bugs on Launchpad regarding this issue. These may help:
https://bugs.launchpad.net/hplip/+bug/802780
https://bugs.launchpad.net/hplip/+bug/718092
https://answers.launchpad.net/hplip/+question/161346

share|improve this answer
    
Did this for both lp and lpadmin but did not seem to help. Do I need to restart some service too? –  Marcus Johansson Jul 27 '12 at 9:35
    
Check your config files. One user previously had the same error, while the actual problem was in /etc/cups/client.conf. This is a open bug on launchpad –  darnir Jul 27 '12 at 9:38
    
Fixed my client.conf and restarted cups. I now get "Printer queue setup failed." Could not connect to CUPS Server. –  Marcus Johansson Jul 27 '12 at 9:43
    
Try rebooting the machine once if possible. This is to make sure the user is granted all access privileges that it is entitled to because of its groups. –  darnir Jul 27 '12 at 9:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.