Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
sudo apt-get update giving error about duplicate

When I tried to update my computer by write command in terminal, there is error shown on the terminal as follows

Reading package lists... Done
W: Duplicate sources.list entry http://dl.google.com/linux/chrome/deb/ stable/main amd64 Packages (/var/lib/apt/lists/dl.google.com_linux_chrome_deb_dists_stable_main_binary-amd64_Packages)
W: Duplicate sources.list entry http://dl.google.com/linux/chrome/deb/ stable/main i386 Packages (/var/lib/apt/lists/dl.google.com_linux_chrome_deb_dists_stable_main_binary-i386_Packages)
W: You may want to run apt-get update to correct these problems
share|improve this question

marked as duplicate by Anwar Shah, Mitch, izx, Caesium, jokerdino Jul 28 '12 at 6:35

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Please include the contents of /etc/apt/sources.list –  nickguletskii Jul 27 '12 at 11:23
add comment

1 Answer 1

First of all, have you tried what it suggests - running apt-get update (which isn't the same as apt-get upgrade)?

After that, take a look at what it's complaining about. It says there are duplicate sources.list entries (looks like you tried to install both the 64bit and 32bit version of Chrome?). Open up the Ubuntu Software Center, then go to Edit -> Software Sources. Then click on the "Other Software" tab and look for the source entries listed in your error (alternatively, you can open up /etc/apt/sources.list, then find the entries there).

Make sure you only have one of the Chrome source entries enabled, and that it matches your architecture (ie - if you installed 64-bit, then you'll want to keep the "amd64" package). You can find out what version you have by going to System Settings -> Details and look for the "OS Type" item in the "Overview" section.

Once you've disabled the unnecessary Chrome source entries, run apt-get update again, you should then be able to run apt-get upgrade without issue.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.