Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have installed Ubuntu 12. 04 in a separate partition in a pre-installed Windows 7 laptop.

Initially when I start up the machine it gives me a menu to choose between two OSs.Then after updating Ubuntu system by default boots to Ubuntu. So I posted a question here with the help of one response now I get the default boot to windows7.

But I want boot menu at each startup to choose between Windows and Ubuntu. I have tried easyBCD. After adding an entry in easybcd a boot menu appears in startup.But when I choose Ubuntu after a black screen the purple screen of Ubuntu comes for 2-3seconds and then Windows is booted.

share|improve this question
Needs confirmation: are you using wubi installation? What change did you made? (at least point us to the instruction you followed) – Web-E Jul 27 '12 at 11:19
No, i have not used wubi installation.I installed ubuntu in a separate partition. – Feynman Jul 27 '12 at 14:16
How want want to choose ubuntu - windows? via windows bootloader or grub. Grub is much easier to setup – Web-E Jul 27 '12 at 14:17
Since i can boot to my windows os i think windows bootloader is my option. – Feynman Jul 27 '12 at 14:45
I think I know what's wrong but am unsure of how to explain a fix I think that grub-timeout=0 may have been added (just a guess) – Grammargeek Jun 17 '15 at 2:46

Do you have the Windows DVD? Enter the DVD, click on Repair, then click repair boot. It should add Windows 7 (but the Ubuntu system will be removed).

Boot to Windows and use Easy BCD.

The non-commercial version is enough. After installing choose Ubuntu and other relevant settings and you will be done.

share|improve this answer
I can boot into Windows.In easybcd i follow these steps: Add new entry>Linux/BSD>Type GRUB2>Add entry>BCD deployment>Install the windows7 loader>Write MBR. But that doesn't help. – Feynman Jul 27 '12 at 14:17

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.