Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My ubuntu boot screen shows up in a strange low resolution, almost text mode, instead the usual and sleek white "ubuntu" over dark background. It's not a big issue because when GDM loads everything becomes ok, but If there's an easy way to fix it I would like to give it a try.

share|improve this question
    
What graphic card and which driver is your machine on? –  Takkat Dec 10 '10 at 17:35
    
@Takkat I'm using a ATI with proprietary driver –  t3mujin Dec 10 '10 at 17:53
add comment

2 Answers

up vote 14 down vote accepted

There is a work around for the problems with proprietary drivers and Plymouth which has worked for me with Nvidia drivers.

  1. Install the package v86d install v86d.

  2. Back up and edit the file /etc/default/grub:

    cp /etc/default/grub ~/.etc.default.grub && gksudo gedit /etc/default/grub
    

    Replace the line that looks like GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" with

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset video=uvesafb:mode_option=1280x1024-24,mtrr=3,scroll=ywrap"
    

    and the line that looks like #GRUB_GFXMODE=640x480 with GRUB_GFXMODE=1280x1024.

    In both of these edits, replace 1280x1024 with your desired screen resolution. Make sure you save the file and exit the text editor once you have finished editing.

  3. Now edit /etc/initramfs-tools/modules just like you did with the previous file:

    cp /etc/initramfs-tools/modules ~/.etc.initramfs-tools.modules && gksudo gedit /etc/initramfs-tools/modules
    

    Add uvesafb mode_option=1280x1024-24 mtrr=3 scroll=ywrap to the end of the file then save and close.

  4. Now edit the file /etc/initramfs-tools/conf.d/splash (which may not exist):

    gksudo gedit /etc/initramfs-tools/conf.d/splash 
    

    Add this to the file: FRAMEBUFFER=y

  5. Run sudo update-grub2 then sudo update-initramfs -u.

  6. Reboot and feast your eyes on the beauty :)

share|improve this answer
    
Yep, I can confirm that these steps will fix it. bug: bugs.launchpad.net/ubuntu/+source/plymouth/+bug/563878 workaround source: news.softpedia.com/news/… –  Ramón Dec 10 '10 at 21:16
    
Only now I has the opportunity to test this. Perfect! –  t3mujin Dec 11 '10 at 1:17
    
Unfortunately these steps don't work for all resolutions. I can only ever get 2380x1024 working, but not my monitors native resolution. –  zookalicious Aug 31 '11 at 14:54
    
Thank you. Works for me on 13.04 –  SimplySimon Jun 3 '13 at 6:50
add comment

You must be using the proprietary nvidia or fglrx driver. Install startupmanager and try to change the bootloader resolution to one that your monitor supports.

share|improve this answer
    
i used startupmanager to change the bootloader's resolution and, for 1024x768 it worked but it doesn't list my configured monitor's resolution of 1366x768. also, it seems to hang the boot with a blank (black) screen and no disk activity for about 5seconds. –  mwm Dec 10 '10 at 17:52
    
I have the fglrx driver installed, I'll give it a go with startupmanager later today (not at my desktop righ now) and share the results. –  t3mujin Dec 10 '10 at 17:54
    
Here, plymouth splash is fine using radeon driver, no need for fglrx –  Takkat Dec 10 '10 at 17:58
    
with radeon it displays well but fglrx is a much better driver for 3d graphics and hardware acceleration –  mwm Dec 10 '10 at 18:03
    
I do not think startupmanager has support for widescreen monitors at this moment. Trying playing outwith the options and see what suits you the best. –  tinhed Dec 10 '10 at 18:12
show 1 more comment

protected by Community May 9 '11 at 3:09

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.