Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've installed the following version of ubuntu om my machine.

ubuntu-12.04-desktop-i386.iso

But when I switch on the computer, I get command line.

Ubuntu 12.04 LTS COMP-1245 tty1

Once I provide my username and password, it authenticates login and then displays a link to documentation.

Now, how can I start GUI? I'm stuck at command line?

share|improve this question
4  
Try typing startx – Mitch Jul 27 '12 at 8:38
    
I got this --bash: startx: command not found – sushanghimire Jul 27 '12 at 8:41
3  
Have you tried pressing Ctrl+Alt+F7? – Peachy Jul 28 '12 at 4:46
    
@Peachy, is it possible to have more than one GUI. For example, with F7 I have my GUI and with F8, another? – Sigur Feb 4 '14 at 15:45
up vote 39 down vote accepted

If you tried the command startx, but the error command not found was returned, then to install a graphical desktop, in case it is not installed, you would type this:

sudo apt-get install ubuntu-desktop
share|improve this answer
1  
Thanks that did it. But why was it not installed while installing the OS itself? – sushanghimire Jul 27 '12 at 8:59
2  
@MrGhimire It should've been. Are you sure you didn't install with the minimal or server CD? You did say you used the desktop CD, but I don't see how that could've installed Ubuntu without gnome. – geirha Jul 27 '12 at 10:42
    
@MrGhimire The minimal CD has a menu that asks if you'd like to install extra packages. Among these are ubuntu-desktop, as well a couple other desktops. Select it and make sure to press space on it, then enter to continue. If you just press enter, it'll skip it. – JVE999 May 8 '14 at 2:04
    
(On my VMware player) Is said ubuntu-desktop is already the newest version. after reboot it is again opening in command line. – student Jun 18 '15 at 8:49

Try to use startx in your tty , if it does not work on one terminal try ctrl+ alt + [F1 to F6] in order to switch a new tty

share|improve this answer
    
This brings up a background image, and if I right click I get a menu containing "New Folder" , "New Document" etc but nothing useful. I don't get any kind of usable desktop, no dock, not menu bar, nothing. – Michael Jun 18 '15 at 18:55

I have had the same problem. Solution is as the said try and install Xorg and the Ubuntu Desktop. also don't forget the build essential pkg

    $ sudo apt-get install build-essential
    $ sudo apt-get install ubuntu-desktop

you might have to install xorg seperate but also! Take advantage of this Command Line because (for my situation) Ubuntu kept trying to use my display port. I almost feel 12.04 has more bugs then the previous releases.

share|improve this answer
    
Why is build-essential needed? It is a tool helping the compilation of programs. While it is, for a developer, useful to have installed - I don't see any compiling in the solution. Unless you want to compile ubuntu-desktop? – Bharadwaj Raju Mar 20 at 17:02

protected by Community Jun 3 '13 at 16:46

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.