Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I had a company computer(ubuntu 12.04LTS) taken home. My home use DSL and my company use LAN to connect to internet. The computer works well in my company, but I have to config it after taken home. I used pppoeconf to config the DSL successfully at home. and use pon dsl-provider to connect to internet. But after I take the computer back to company, I had to change back to LAN. After Google it, I modified the file /etc/network/interfaces

auto lo
iface lo inet loopback

auto dsl-provider
iface dsl-provider inet ppp
pre-up /sbin/ifconfig eth0 up # line maintained by pppoeconf
provider dsl-provider

auto eth0
iface eth0 inet manual

to

auto lo
iface lo inet loopback

#auto dsl-provider
#iface dsl-provider inet ppp
#pre-up /sbin/ifconfig eth0 up # line maintained by pppoeconf
#provider dsl-provider

#auto eth0
#iface eth0 inet manual

but this does not work: When reboot the computer, the network-manager shows wired network already connected, but not show the "Wired connection 1". ifconfig shows eth0 have ip address 192.168.1.108, but cannot connect to internet. I tried to add Wired Connection 1 manually, choose the MAC of eth0 in Device MAC address, and save. It shows: Connection add failed , Connecttion not visible or not available. (I thought it should work here. DHCP/Manual ip addresses both works well several day before.)

I had several other tries: I changed the /etc/network/interfaces file to

auto lo
iface lo inet loopback

#auto dsl-provider
#iface dsl-provider inet ppp
#pre-up /sbin/ifconfig eth0 up # line maintained by pppoeconf
#provider dsl-provider

auto eth0
iface eth0 inet manual

still not work. and changed to some static ip address not work, either. I think that pppoeconf make some change to the network-manager configuration or networking config, so that after stopped pppd, the network-manager does not work. Please give me some advices, thanks!

share|improve this question

2 Answers 2

Same problem with you.

Those guys' tries may help you solve this problem:
http://ubuntuforums.org/showthread.php?p=12111017

share|improve this answer
    
Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Eliah Kagan Aug 3 '12 at 17:46

i have the same problem i solved it like this

Edit /etc/NetworkManager/nm-system-settings.conf file by using

sudo gedit /etc/NetworkManager/nm-system-settings.conf

find and change “managed=true” (without quotes).

Edit /etc/network/interfaces,

sudo gedit /etc/network/interfaces change its content to:


auto lo

iface lo inet loopback


Delete /etc/resolv.conf by this command:

sudo rm -rf /etc/resolv.conf

Now,restart machine or restart the network-manager by this command:

sudo /etc/init.d/network-manager restart

Add DSL connection to network-manager and make it auto-connect at login.

Right click on network-manager icon and select “edit connections”

Delete useless connection.In DSL tab,click Add and then input your Username and Password.

Remember check the “Available to all users” to prevent keyring locked problem.

SUGGESTION i will suggest to keep using pppoeconf command because by using network manager MTU problem can give you headache, which causes slow internet and most of the sites won't load. just have a look at this thread

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.